summaryrefslogtreecommitdiff
path: root/recipes-core/multitech
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-08-28 15:25:44 -0500
committerJohn Klug <john.klug@multitech.com>2017-09-14 17:31:50 -0500
commitbab089e8a10852a6262c26b67459a8b7045fd0a6 (patch)
tree848c254f0bee9616758c0e18d6a03220204e2471 /recipes-core/multitech
parent1e07a786112f7217bca318c55a37f4123e9a2b45 (diff)
downloadmeta-mlinux-bab089e8a10852a6262c26b67459a8b7045fd0a6.tar.gz
meta-mlinux-bab089e8a10852a6262c26b67459a8b7045fd0a6.tar.bz2
meta-mlinux-bab089e8a10852a6262c26b67459a8b7045fd0a6.zip
Move fwswitch script to mlinux-scripts, and call it mlinux-switch-cell-fw
Diffstat (limited to 'recipes-core/multitech')
-rw-r--r--recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.default2
-rw-r--r--recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.init57
-rwxr-xr-xrecipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.sh114
-rw-r--r--recipes-core/multitech/cell-radio-fwswitch_1.0.bb36
4 files changed, 0 insertions, 209 deletions
diff --git a/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.default b/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.default
deleted file mode 100644
index a19e18e..0000000
--- a/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.default
+++ /dev/null
@@ -1,2 +0,0 @@
-# set to "yes" to enable cell-radio-fwswitch on boot
-ENABLED="no"
diff --git a/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.init b/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.init
deleted file mode 100644
index 82b5cb5..0000000
--- a/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.init
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-
-# no firmware switch by default
-ENABLED="no"
-# radio come up timeout
-TIMEOUT=15
-# default radio firmware image id
-FWIMAGE="0"
-
-[ -r /etc/default/cell-radio-fwswitch ] && source /etc/default/cell-radio-fwswitch
-[ "$ENABLED" == "yes" ] || exit 0
-
-function start() {
- FWACTIVE=$(radio-query --active-firmware)
- if [[ $? != 0 || x"$FWACTIVE" == x"" ]]; then
- # radio does not support firmware switching.
- exit 0
- fi
-
- FWSWITCH=$(curl -s 127.0.0.1/api/ppp/modem/fwSwitch | jsparser -p /result/)
- if [[ x"$FWSWITCH" == x"" ]]; then
- echo "Failed to obtain the radio firmware image id to use."
- exit 1
- fi
-
- if [[ "$FWSWITCH" == "att" ]]; then
- FWIMAGE="0"
- elif [[ "$FWSWITCH" == "vz" ]]; then
- FWIMAGE="1"
- else
- # autodetect
- ICCID=$(radio-query --iccid)
- if [ $? -ne 0 ]; then
- exit 0
- fi
- if [[ "$ICCID" =~ ^89148.* ]]; then
- #
- # Switch to FW image #1 for Verizon SIMs
- #
- FWIMAGE="1"
- fi
- fi
-
- cell-radio-fwswitch $FWIMAGE $TIMEOUT
-}
-
-case $1 in
- start)
- start
- ;;
-
- *)
- echo "Usage: $0 {start}"
- exit 2
- ;;
-esac
-
diff --git a/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.sh b/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.sh
deleted file mode 100755
index a101e56..0000000
--- a/recipes-core/multitech/cell-radio-fwswitch/cell-radio-fwswitch.sh
+++ /dev/null
@@ -1,114 +0,0 @@
-#!/bin/sh
-
-
-if [ $# -gt 2 ] || [ $# -lt 1 ]; then
-echo "\
-Usage: $0 <image_id> [timeout]
- image_id <0|1> : for dual FW image SKU-s, the id of the image to switch to
- (LTE910-NA1 is the only supported radio for now).
- timeout : wait time for radio to come up if set (default : 15 sec)
-"
- exit 1
-fi
-
-#
-# Load args (don't wait for the radio by default)
-#
-FWIMAGE=$1
-TIMEOUT=${2:-15}
-if [ "$VERBOSE" != "yes" ]; then
- VERBOSE=""
-fi
-
-[ "$VERBOSE" ] && echo -n "Switching the radio firmware image: "
-
-#
-# Check if the radio present
-#
-MODEL=$(radio-query --model)
-if [ $? -ne 0 ]; then
- [ "$VERBOSE" ] && echo "Assume no radio on this device."
- exit 0
-fi
-
-#
-# Applicable for LTE910-NA1 with dual FW images only
-#
-if [ "$MODEL" != "LE910-NA1" ]; then
- [ "$VERBOSE" ] && echo "Firmware switch is supported only on LE910-NA1 models."
- exit 0
-fi
-
-#
-# Check if firmware switch is required
-#
-FWACTIVE=$(radio-query --active-firmware)
-if [ $? -ne 0 ] || [ "$FWACTIVE" == "" ]; then
- [ "$VERBOSE" ] && echo "The $MODEL radio does not support firmware switching."
- exit 0
-fi
-
-if [ "$FWACTIVE" == "$FWIMAGE" ]; then
- [ "$VERBOSE" ] && echo "The radio firmware image is already set."
- exit 0
-fi
-
-# Verizon does not want an APN, so remove first
-if ((FWIMAGE == 1)) ; then
- /usr/sbin/mlinux-switch-apn $FWIMAGE
-fi
-
-
-#
-# Switch the firmware
-#
-RESULT=$(radio-cmd --set-active-firmware "$FWIMAGE")
-if [ $? -ne 0 ]; then
- echo "$RESULT"
- exit 1
-fi
-
-
-#
-# Exit if no TIMEOUT set
-#
-# This is somewhat dangerous in that we assume the radio
-# will switch.
-if ((TIMEOUT == 0)) ; then
- if ((FWIMAGE == 0)) ; then
- echo "Use mlinux-switch-apn to switch the APN when the radio is ready, before dialing"
- exit 0
- fi
-fi
-
-#
-# Wait for the radio to be ready before continuing
-#
-COUNTER=0
-
-[ "$VERBOSE" ] && echo -n "Wait..."
-
-#
-# Give it some time
-#
-sleep 5
-
-while [ $COUNTER -lt $TIMEOUT ]; do
- MODEL=$(radio-query --model)
- if [ $? -eq 0 ]; then
- echo "Cellular radio firmware has been switched to $FWIMAGE image."
- ((FWIMAGE == 0)) && /usr/sbin/mlinux-switch-apn $FWIMAGE
- exit 0
- fi
-
- let COUNTER=COUNTER+1
-
- [ "$VERBOSE" ] && echo -n "."
-
- sleep 1
-done
-
-echo "Cellular radio is not ready."
-echo "When it becomes ready, invoke /usr/sbin/mlinux-switch-apn"
-echo "to set the APN"
-exit 1
diff --git a/recipes-core/multitech/cell-radio-fwswitch_1.0.bb b/recipes-core/multitech/cell-radio-fwswitch_1.0.bb
deleted file mode 100644
index 93a058c..0000000
--- a/recipes-core/multitech/cell-radio-fwswitch_1.0.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "Radio firmware switching functionality for dual image units (only LNA3 radios for now)"
-SECTION = "base"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-PR = "r1"
-
-RDEPENDS_${PN} = "radio-query radio-cmd"
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "cell-radio-fwswitch"
-INITSCRIPT_PARAMS = "start 63 5 ."
-
-# remove fwswitch, since radio might not be ready.
-
-SRC_URI = "\
- file://cell-radio-fwswitch.sh \
-"
-# file://cell-radio-fwswitch.default
-# file://cell-radio-fwswitch.init
-
-do_install () {
- #install -d ${D}${sysconfdir}/init.d
- #install -m 0755 ${WORKDIR}/cell-radio-fwswitch.init ${D}${sysconfdir}/init.d/cell-radio-fwswitch
-
- #install -d ${D}${sysconfdir}/default
- #install -m 0644 ${WORKDIR}/cell-radio-fwswitch.default ${D}${sysconfdir}/default/cell-radio-fwswitch
-
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/cell-radio-fwswitch.sh ${D}${sbindir}/cell-radio-fwswitch
-}
-
-do_install_append_mtcap() {
- # enable cell-radio-fwswitch init script on boot for MTCAP
- sed -i 's/ENABLED="no"/ENABLED="yes"/g' ${D}${sysconfdir}/default/cell-radio-fwswitch
-}