summaryrefslogtreecommitdiff
path: root/recipes-core/mlinux
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-01-23 15:28:24 -0600
committerJesse Gilles <jgilles@multitech.com>2015-01-23 15:28:24 -0600
commit10e9058fcd1f0e7050848945c183528aadae8db0 (patch)
tree9e3f989d009a984fcad03609653da4604ea4d458 /recipes-core/mlinux
parent5f6b9bdc1568a0c657ce4f13195e13911f9be955 (diff)
downloadmeta-mlinux-10e9058fcd1f0e7050848945c183528aadae8db0.tar.gz
meta-mlinux-10e9058fcd1f0e7050848945c183528aadae8db0.tar.bz2
meta-mlinux-10e9058fcd1f0e7050848945c183528aadae8db0.zip
mlinux-version: move to recipes-core/mlinux
Diffstat (limited to 'recipes-core/mlinux')
-rw-r--r--recipes-core/mlinux/mlinux-version.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-core/mlinux/mlinux-version.bb b/recipes-core/mlinux/mlinux-version.bb
new file mode 100644
index 0000000..f2debe1
--- /dev/null
+++ b/recipes-core/mlinux/mlinux-version.bb
@@ -0,0 +1,22 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit mlinux_metadata_scm
+
+# always parse this file so PV can change automatically
+__BB_DONT_CACHE = "1"
+
+PV = "${DISTRO_VERSION}_${MLINUX_METADATA_REVISION}"
+PR = "r2"
+PE = "1"
+
+PACKAGES = "${PN}"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_install() {
+ mkdir -p ${D}${sysconfdir}
+ echo "mLinux ${DISTRO_VERSION}" > ${D}${sysconfdir}/mlinux-version
+ echo "Built from branch: ${MLINUX_METADATA_BRANCH}" >> ${D}${sysconfdir}/mlinux-version
+ echo "Revision: ${MLINUX_METADATA_REVISION}" >> ${D}${sysconfdir}/mlinux-version
+ echo "${MLINUX_LAYERS}" > ${D}${sysconfdir}/mlinux-layers
+}