summaryrefslogtreecommitdiff
path: root/recipes-core/libusb/libusb1/no-dll.patch
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-12-05 18:11:44 -0600
committerJohn Klug <john.klug@multitech.com>2017-12-05 18:11:44 -0600
commit07ba917a4433d44a559ed8db0bd7ee4fb85a2ad0 (patch)
tree9bb893e5b617de2a4415906685e974b8341fa732 /recipes-core/libusb/libusb1/no-dll.patch
parent531ce0abd2472ff6fc65843fb7d5a73af38f7826 (diff)
downloadmeta-mlinux-07ba917a4433d44a559ed8db0bd7ee4fb85a2ad0.tar.gz
meta-mlinux-07ba917a4433d44a559ed8db0bd7ee4fb85a2ad0.tar.bz2
meta-mlinux-07ba917a4433d44a559ed8db0bd7ee4fb85a2ad0.zip
libusb1-1.0.21
Diffstat (limited to 'recipes-core/libusb/libusb1/no-dll.patch')
-rw-r--r--recipes-core/libusb/libusb1/no-dll.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-core/libusb/libusb1/no-dll.patch b/recipes-core/libusb/libusb1/no-dll.patch
new file mode 100644
index 0000000..6e6bb83
--- /dev/null
+++ b/recipes-core/libusb/libusb1/no-dll.patch
@@ -0,0 +1,19 @@
+As all invokes all-recursive which uses sub-makes to invoke all-am, the
+resulting makefile wants to build libusb-1.0.la twice. In non-parallel builds
+the second attempt is skipped as the target already exists, but in highly
+parallel builds it's likely that two makes will be building libusb-1.0.la at the
+same time.
+
+Solve this by removing the explicit all target, which as libusb-1.0.dll isn't
+built under Linux is redundant anyway.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/libusb/Makefile.am b/libusb/Makefile.am
+index 0cab0a0..c880213 100644
+--- a/libusb/Makefile.am
++++ b/libusb/Makefile.am
+@@ -1,2 +0,0 @@
+-all: libusb-1.0.la libusb-1.0.dll
+-