summaryrefslogtreecommitdiff
path: root/recipes-core/images
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-02-28 22:41:27 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 17:08:20 -0500
commit83d1df546401d6f3098ceb80b805856b8192e39c (patch)
tree651a2d5ea9d74be7f6f4860d7a523ab2c77e0799 /recipes-core/images
parent5094447a35fd2163f76f0027ca0cd89e0e3cdfff (diff)
downloadmeta-mlinux-83d1df546401d6f3098ceb80b805856b8192e39c.tar.gz
meta-mlinux-83d1df546401d6f3098ceb80b805856b8192e39c.tar.bz2
meta-mlinux-83d1df546401d6f3098ceb80b805856b8192e39c.zip
Add mtrv1 image with rs9113 for testing
Diffstat (limited to 'recipes-core/images')
-rw-r--r--recipes-core/images/mlinux-mtrv1-image.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-core/images/mlinux-mtrv1-image.bb b/recipes-core/images/mlinux-mtrv1-image.bb
new file mode 100644
index 0000000..1eca91a
--- /dev/null
+++ b/recipes-core/images/mlinux-mtrv1-image.bb
@@ -0,0 +1,71 @@
+require mtr-modules.inc
+DESCRIPTION = "mLinux base mtr image"
+LICENSE = "MIT"
+
+require mlinux-minimal-image.bb
+MULTITECH_MTAC = ""
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ busybox-ifplugd \
+ "
+
+WIFI_FEATURES = " \
+ libnl \
+ wpa-supplicant \
+ wireless-tools \
+ iw \
+ hostap-daemon hostap-utils \
+ "
+
+BLUETOOTH_FEATURES = "bluez5"
+
+# Add all timezones available
+# ntpdate will sync time every 30 min by default via cron
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+# u-boot-linux-utils: U-Boot environment access from Linux
+# mlinux-scripts: sample scripts for setting up Conduit for various tasks
+# reset-handler: default reset button handler
+# radio-cmd: supports cellular radio activation and other configuration commands
+# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
+# jsparser: command line tool to parse JSON files
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ "
+
+MISC_FEATURES = "minicom lrzsz nano"
+
+# Extra stuff to install
+IMAGE_INSTALL += "kernel-module-rs9113 rs9113-noarch rs9113-util"
+IMAGE_INSTALL += "gpsd libgps ntp ntp-utils gpspipe gps-utils"
+
+IMAGE_INSTALL += " \
+ ${WIFI_FEATURES} \
+ ${BLUETOOTH_FEATURES} \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${MISC_FEATURES} \
+ "