summaryrefslogtreecommitdiff
path: root/recipes-core/images/mlinux-factory-image.bb
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-04-17 16:47:24 -0500
committerJesse Gilles <jgilles@multitech.com>2015-04-17 16:47:24 -0500
commit121a8cc507eed3c8d54f79f6b3e52e1568734c85 (patch)
tree8d2f0a969c063b83280e81a7a2036c9450eb172d /recipes-core/images/mlinux-factory-image.bb
parent0810d3413d4dda35c8dfb8fa1ef179dda3a59ebd (diff)
downloadmeta-mlinux-121a8cc507eed3c8d54f79f6b3e52e1568734c85.tar.gz
meta-mlinux-121a8cc507eed3c8d54f79f6b3e52e1568734c85.tar.bz2
meta-mlinux-121a8cc507eed3c8d54f79f6b3e52e1568734c85.zip
mlinux-factory-image: add more python modules
Diffstat (limited to 'recipes-core/images/mlinux-factory-image.bb')
-rw-r--r--recipes-core/images/mlinux-factory-image.bb26
1 files changed, 19 insertions, 7 deletions
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 20164e5..bc84786 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -15,7 +15,6 @@ IMAGE_INSTALL += "${LIGHTTPD}"
IMAGE_INSTALL += "sqlite3"
IMAGE_INSTALL += "autossh"
-IMAGE_INSTALL += "netcat"
# Perl support
IMAGE_INSTALL += "perl"
@@ -26,12 +25,25 @@ IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
# Python support
IMAGE_INSTALL += "python"
-IMAGE_INSTALL += "python-pyserial"
-IMAGE_INSTALL += "python-simplejson"
-IMAGE_INSTALL += "python-unixadmin"
-IMAGE_INSTALL += "python-textutils"
-IMAGE_INSTALL += "python-html"
-IMAGE_INSTALL += "python-sqlite3"
+# Python modules
+IMAGE_INSTALL += "python-async \
+python-argparse \
+python-compression \
+python-dateutil \
+python-html \
+python-psutil \
+python-pycurl \
+python-pyopenssl \
+python-pyserial \
+python-pyudev \
+python-pyusb \
+python-simplejson \
+python-sqlite3 \
+python-syslog \
+python-textutils \
+python-unixadmin \
+python-xml \
+"
# Ruby support
IMAGE_INSTALL += "ruby"