summaryrefslogtreecommitdiff
path: root/recipes-core/annex-client/annex-client-from-src.bb
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-11-10 12:58:37 -0600
committerJason Reiss <jreiss@multitech.com>2016-11-10 12:58:37 -0600
commite093123ceafca8eb6d8d041e0ad09f67d1202c73 (patch)
tree009fbbbb4c6ece6b88f5006d78a8d2ab85a835f4 /recipes-core/annex-client/annex-client-from-src.bb
parent75fd65e9f52aeea9ab27b4af85c1fa8b093e5be3 (diff)
parent38ded95350a89cae973df774242e3c35e98784d8 (diff)
downloadmeta-mlinux-e093123ceafca8eb6d8d041e0ad09f67d1202c73.tar.gz
meta-mlinux-e093123ceafca8eb6d8d041e0ad09f67d1202c73.tar.bz2
meta-mlinux-e093123ceafca8eb6d8d041e0ad09f67d1202c73.zip
merge: Conduit_0.1 changes into master
lora: update lora-network-server to 1.0.16
Diffstat (limited to 'recipes-core/annex-client/annex-client-from-src.bb')
-rw-r--r--recipes-core/annex-client/annex-client-from-src.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-core/annex-client/annex-client-from-src.bb b/recipes-core/annex-client/annex-client-from-src.bb
new file mode 100644
index 0000000..ee7dee9
--- /dev/null
+++ b/recipes-core/annex-client/annex-client-from-src.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Provides the Multi-Tech MDM client"
+SECTION = "remote-management"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PROVIDES = "annex-client-from-src"
+DEPENDS = "jsoncpp curl protobuf cyrus-sasl protobuf-native annex-proto mts-io"
+
+PR = "r0"
+SRCREV = "a696a7660bf153fec126cf971442c60961c51782"
+
+SRC_URI = "git://git@${MTS_INTERNAL_GIT}/multitech/annex-client.git;protocol=ssh;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ echo "directory: `pwd`"
+ mkdir -p annex_pb
+ cp ${STAGING_DIR_NATIVE}/annex.proto annex_pb/
+ make all CFLAGS+="-DMLINUX_BUILD"
+}
+
+# IMPORTANT NOTE:
+# this recipe is only used for the annex-client Jenkin's job to build IPK.
+# annex-client.bb is used to install the binary in an image
+do_install() {
+ oe_runmake install DESTDIR=${D} SUBDIRS="src"
+}