summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2015-07-30 11:16:01 -0500
committerJason Reiss <jreiss@multitech.com>2015-07-30 11:16:01 -0500
commit31096a338de0f580928e31877a7a36052ba8ac22 (patch)
tree656f159d704462343f90d3d4e4a002e98fbfc530 /recipes-connectivity
parent1eb44503354d29b0ba9db542f63e9d03803e2208 (diff)
downloadmeta-mlinux-31096a338de0f580928e31877a7a36052ba8ac22.tar.gz
meta-mlinux-31096a338de0f580928e31877a7a36052ba8ac22.tar.bz2
meta-mlinux-31096a338de0f580928e31877a7a36052ba8ac22.zip
lora: update network server to 0.0.6
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-network-server_0.0.6.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_0.0.6.bb b/recipes-connectivity/lora/lora-network-server_0.0.6.bb
new file mode 100644
index 0000000..b381893
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_0.0.6.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r0"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "696cd785cdc06a1b1db6ac1037e97e5d"
+SRC_URI[sha256sum] = "3d91c662563c1838b4e43040ca8a6b357fa89fd08f3baa9a352f423a1914c077"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"