summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server_1.0.16.bb
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-11-10 12:58:37 -0600
committerJason Reiss <jreiss@multitech.com>2016-11-10 12:58:37 -0600
commite093123ceafca8eb6d8d041e0ad09f67d1202c73 (patch)
tree009fbbbb4c6ece6b88f5006d78a8d2ab85a835f4 /recipes-connectivity/lora/lora-network-server_1.0.16.bb
parent75fd65e9f52aeea9ab27b4af85c1fa8b093e5be3 (diff)
parent38ded95350a89cae973df774242e3c35e98784d8 (diff)
downloadmeta-mlinux-e093123ceafca8eb6d8d041e0ad09f67d1202c73.tar.gz
meta-mlinux-e093123ceafca8eb6d8d041e0ad09f67d1202c73.tar.bz2
meta-mlinux-e093123ceafca8eb6d8d041e0ad09f67d1202c73.zip
merge: Conduit_0.1 changes into master
lora: update lora-network-server to 1.0.16
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server_1.0.16.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.16.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.16.bb b/recipes-connectivity/lora/lora-network-server_1.0.16.bb
new file mode 100644
index 0000000..7a3d27c
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_1.0.16.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r1"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "3169970ea9b96656847d7472a2cf1f0f"
+SRC_URI[sha256sum] = "81b3c348911464fccbb70e3ff0c60dbcf77af69c2205aec3591fc2ceff7a5c52"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"