summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server_0.0.8.bb
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2015-10-21 15:58:43 -0500
committerJason Reiss <jreiss@multitech.com>2015-10-21 15:58:43 -0500
commiteb60c9c535be9a16e7f63084f23dd1b687f30ec3 (patch)
treef7e9f8bb6af048f00c14106b0c4ec1f80226459e /recipes-connectivity/lora/lora-network-server_0.0.8.bb
parent2fc8b56bf20c37791931f42359b8099b04808015 (diff)
parent345cfbb0c73f47dcbbe28d50edd8b15b9090a68f (diff)
downloadmeta-mlinux-eb60c9c535be9a16e7f63084f23dd1b687f30ec3.tar.gz
meta-mlinux-eb60c9c535be9a16e7f63084f23dd1b687f30ec3.tar.bz2
meta-mlinux-eb60c9c535be9a16e7f63084f23dd1b687f30ec3.zip
Merge branch 'master' of git.multitech.net:meta-mlinux
Conflicts: recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-add-queue.patch
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server_0.0.8.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server_0.0.8.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_0.0.8.bb b/recipes-connectivity/lora/lora-network-server_0.0.8.bb
new file mode 100644
index 0000000..d2f55e8
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_0.0.8.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r0"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "8cb2686b427a32d53e301e87870b49cf"
+SRC_URI[sha256sum] = "be7de4463f17645882ed6194d9af2bc9a4608005635c8d31d5c5ec8bf552c73f"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"