summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server_0.0.2-11-g82ab10d.bb
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-05-22 14:47:15 -0500
committerJesse Gilles <jgilles@multitech.com>2015-05-22 14:47:15 -0500
commitbfd5846c53d528c16a875f5b2469e1d29381763e (patch)
tree8182631bb580d0a05c05624b7e8a736f4ec983c6 /recipes-connectivity/lora/lora-network-server_0.0.2-11-g82ab10d.bb
parent2fe4b3bfcaef7164f8890d4eec58450e7271b639 (diff)
downloadmeta-mlinux-bfd5846c53d528c16a875f5b2469e1d29381763e.tar.gz
meta-mlinux-bfd5846c53d528c16a875f5b2469e1d29381763e.tar.bz2
meta-mlinux-bfd5846c53d528c16a875f5b2469e1d29381763e.zip
add recipes for initial LoRa support for MTAC-LORA
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server_0.0.2-11-g82ab10d.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server_0.0.2-11-g82ab10d.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_0.0.2-11-g82ab10d.bb b/recipes-connectivity/lora/lora-network-server_0.0.2-11-g82ab10d.bb
new file mode 100644
index 0000000..e64e482
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_0.0.2-11-g82ab10d.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r0"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "139a4f82af1ea3afcbe0f4924aedcc0d"
+SRC_URI[sha256sum] = "9639ea5ff8cdd6d9979dae010aef8c6011607fb1c0e2e4083d94e405e40ac8cb"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"