summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-11-09 12:04:31 -0600
committerBrandon Bayer <bbayer@multitech.com>2016-11-09 12:04:31 -0600
commitf11702ca3ca8fc875ee85763710ab178cf7be364 (patch)
treea59d18c4e4119592fc51215c5be8f8f9b875aece /recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb
parent5964212dc0249408e2cf944f17b489fe814bd52f (diff)
downloadmeta-mlinux-f11702ca3ca8fc875ee85763710ab178cf7be364.tar.gz
meta-mlinux-f11702ca3ca8fc875ee85763710ab178cf7be364.tar.bz2
meta-mlinux-f11702ca3ca8fc875ee85763710ab178cf7be364.zip
mtcap:feat: upgrade lora-network-server
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb b/recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb
new file mode 100644
index 0000000..3eae827
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb
@@ -0,0 +1,49 @@
+# THIS RECIPE FOR PICOCELL USES PATCHED LORA NETWORK SERVER THAT SUPPORTS
+# MTCAP HARDWARE AND V2 PACKET FORWARDER PROTOCOL
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r2"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_arm926ejste_1.0.15-2-g642a748.tar.gz \
+ file://lora-network-server.conf \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ file://local_conf.json \
+ "
+
+SRC_URI[md5sum] = "6cbae4e82503c5b5078b4ffadcda05a0"
+SRC_URI[sha256sum] = "707e919b02f1f7d3ef8ed66f26b7e8749f4d0db55288062f1aa4c04e5ceccf34"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 ${WORKDIR}/lora-network-server.conf ${D}${LORA_DIR}/
+ install -m 0755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"