summaryrefslogtreecommitdiff
path: root/recipes-connectivity/hostapd/hostap-daemon_2.4.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-12-01 11:41:30 -0600
committerJohn Klug <john.klug@multitech.com>2016-12-01 11:41:30 -0600
commit1c32f8662c4f02de9379418d35c3089750bd770a (patch)
tree24becac7322716b29742edc08eeadf800a8eff7d /recipes-connectivity/hostapd/hostap-daemon_2.4.bb
parent5194efc0b80e560933daf0171e56c2b379586a08 (diff)
downloadmeta-mlinux-1c32f8662c4f02de9379418d35c3089750bd770a.tar.gz
meta-mlinux-1c32f8662c4f02de9379418d35c3089750bd770a.tar.bz2
meta-mlinux-1c32f8662c4f02de9379418d35c3089750bd770a.zip
Do not start hostapd unless configured
Diffstat (limited to 'recipes-connectivity/hostapd/hostap-daemon_2.4.bb')
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon_2.4.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-connectivity/hostapd/hostap-daemon_2.4.bb b/recipes-connectivity/hostapd/hostap-daemon_2.4.bb
index 863f895..9244da4 100644
--- a/recipes-connectivity/hostapd/hostap-daemon_2.4.bb
+++ b/recipes-connectivity/hostapd/hostap-daemon_2.4.bb
@@ -17,7 +17,7 @@ SRC_URI += " \
http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
file://defconfig \
file://init \
- file://init.patch;patchdir=${WORKDIR} \
+ file://default \
"
S = "${WORKDIR}/hostapd-${PV}/hostapd"
@@ -36,3 +36,8 @@ CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
SRC_URI[md5sum] = "04578f3f2c3eb1bec1adf30473813912"
SRC_URI[sha256sum] = "6fe0eb6bd1c9cbd24952ece8586b6f7bd14ab358edfda99794e79b9b9dbd657f"
+
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/default
+ install -m 644 ${WORKDIR}/default ${D}${sysconfdir}/default/hostapd
+}