summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-10-26 09:40:42 -0500
committerJohn Klug <john.klug@multitech.com>2021-12-29 07:10:32 -0600
commitf7c8ecbd96ea5e6319cda3f6515ec568c1dc1f06 (patch)
tree726941754df78d3a13cd2c9a2c1573ed150c27d1
parent014e3fc6a12c7931c5767a12a79632089c0e624a (diff)
downloadmeta-mlinux-f7c8ecbd96ea5e6319cda3f6515ec568c1dc1f06.tar.gz
meta-mlinux-f7c8ecbd96ea5e6319cda3f6515ec568c1dc1f06.tar.bz2
meta-mlinux-f7c8ecbd96ea5e6319cda3f6515ec568c1dc1f06.zip
Fix nonexistant resolv.conf for dnsmasq
-rw-r--r--recipes-connectivity/ppp/files/init.patch16
-rw-r--r--recipes-connectivity/ppp/ppp_%.bbappend2
2 files changed, 11 insertions, 7 deletions
diff --git a/recipes-connectivity/ppp/files/init.patch b/recipes-connectivity/ppp/files/init.patch
index 5aacfae..00ae09a 100644
--- a/recipes-connectivity/ppp/files/init.patch
+++ b/recipes-connectivity/ppp/files/init.patch
@@ -1,19 +1,23 @@
diff -Naru orig/init new/init
---- orig/init 2021-09-01 04:13:34.868409735 -0500
-+++ new/init 2021-09-03 11:00:53.480385352 -0500
-@@ -8,6 +8,11 @@
+--- orig/init 2021-10-26 09:22:52.464566921 -0500
++++ new/init 2021-10-26 09:24:31.144568910 -0500
+@@ -8,6 +8,15 @@
# Source function library.
. /etc/init.d/functions
-+if [[ $RADIORESETWAIT == yes ]]
++. /etc/default/ppp
++if [[ $RADIORESETWAIT == yes ]] ; then
+ . /usr/libexec/ppp/wait_for_reset
+else
+ function wait_for_reset { :; }
+fi
++
++mkdir -p /run/ppp || true
++touch /run/ppp/resolv.conf
test -x /usr/sbin/pppd -a -f /etc/ppp/ppp_on_boot || exit 0
if [ -x /etc/ppp/ppp_on_boot ]; then RUNFILE=1; fi
-@@ -15,7 +20,9 @@
+@@ -15,7 +24,9 @@
case "$1" in
start)
echo -n "Starting up PPP link: pppd"
@@ -23,7 +27,7 @@ diff -Naru orig/init new/init
/etc/ppp/ppp_on_boot
else
pppd call provider
-@@ -37,13 +44,15 @@
+@@ -37,13 +48,15 @@
;;
restart|force-reload)
echo -n "Restarting PPP link: pppd"
diff --git a/recipes-connectivity/ppp/ppp_%.bbappend b/recipes-connectivity/ppp/ppp_%.bbappend
index 510765b..fafe176 100644
--- a/recipes-connectivity/ppp/ppp_%.bbappend
+++ b/recipes-connectivity/ppp/ppp_%.bbappend
@@ -13,7 +13,7 @@ SRC_URI_append = "\
file://wait_for_reset \
file://default"
-PR = "r11"
+PR = "r12"
PACKAGES =+ "${PN}-radioresetwait ${PN}-waitforresetfunc"
FILES_${PN}-waitforresetfunc = "${libexecdir}/ppp/wait_for_reset"