summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-11-04 03:00:31 -0500
committerJohn Klug <john.klug@multitech.com>2021-12-29 07:15:41 -0600
commit8e96d8272e17b528d332e01eabd41dc939725597 (patch)
tree866a1a280da6564c2b8f9569ac2c9f0035d553a8
parent062cc2012a4eac3ccf40e96b478d304937e32dba (diff)
downloadmeta-mlinux-8e96d8272e17b528d332e01eabd41dc939725597.tar.gz
meta-mlinux-8e96d8272e17b528d332e01eabd41dc939725597.tar.bz2
meta-mlinux-8e96d8272e17b528d332e01eabd41dc939725597.zip
Remove error with obsolete feature hotplug
-rw-r--r--recipes-core/udev/eudev/init2
-rw-r--r--recipes-core/udev/eudev_%.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/udev/eudev/init b/recipes-core/udev/eudev/init
index bd716b0..230e993 100644
--- a/recipes-core/udev/eudev/init
+++ b/recipes-core/udev/eudev/init
@@ -97,7 +97,7 @@ case "$1" in
kill_udevd > "/dev/null" 2>&1
# trigger the sorted events
- echo -e '\000\000\000\000' > /proc/sys/kernel/hotplug
+ [ -e /proc/sys/kernel/hotplug ] && echo -e '\000' >/proc/sys/kernel/hotplug
@UDEVD@ -d
udevadm control --env=STARTUP=1
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index 364288e..f669a76 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
RDEPENDS_${PN} += "bash"
-PR .= ".mlinux7"
+PR .= ".mlinux8"
# add custom rules for persistent modem device names
SRC_URI += "file://cellular_radios.rules \