summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-09-13 04:03:53 -0500
committerJohn Klug <john.klug@multitech.com>2021-12-29 07:04:43 -0600
commit17a64f48ded3abdbb758dfd35fe0ce91599d2a64 (patch)
tree325f43b5ba6fe55149951624f47b165861573177
parent0eee4e464974e04fbaae967e9d98cda0e82aec93 (diff)
downloadmeta-mlinux-17a64f48ded3abdbb758dfd35fe0ce91599d2a64.tar.gz
meta-mlinux-17a64f48ded3abdbb758dfd35fe0ce91599d2a64.tar.bz2
meta-mlinux-17a64f48ded3abdbb758dfd35fe0ce91599d2a64.zip
Remove gpsd warnings
-rw-r--r--recipes-navigation/gpsd/gpsd/gpsd-default2
-rw-r--r--recipes-navigation/gpsd/gpsd_3.20.bb24
2 files changed, 3 insertions, 23 deletions
diff --git a/recipes-navigation/gpsd/gpsd/gpsd-default b/recipes-navigation/gpsd/gpsd/gpsd-default
index edd7b08..a3245a3 100644
--- a/recipes-navigation/gpsd/gpsd/gpsd-default
+++ b/recipes-navigation/gpsd/gpsd/gpsd-default
@@ -3,7 +3,7 @@ ENABLED="yes"
# GPSD control socket for sending GPSD commands.
# GPSD_SOCKET="/var/run/gpsd.sock"
-GPSD_OPTIONS="-n -D 1"
+GPSD_OPTIONS="-n -D 0"
# Conduit 0.1 GPS devices
GPS_LINE=/dev/gps0
diff --git a/recipes-navigation/gpsd/gpsd_3.20.bb b/recipes-navigation/gpsd/gpsd_3.20.bb
index 0e78417..eeaf0a3 100644
--- a/recipes-navigation/gpsd/gpsd_3.20.bb
+++ b/recipes-navigation/gpsd/gpsd_3.20.bb
@@ -4,11 +4,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=01764c35ae34d9521944bb6ab312af53"
DEPENDS = "dbus dbus-glib ncurses python3 libusb1 chrpath-replacement-native pps-tools"
PROVIDES = "virtual/gpsd"
-PR="m8"
-
-#TODO
-#the recipe generates python2 pygps package for Atmel based devices and python3 pygps package for TI based devices.
-#later when python2 will be removed the recipe should be returned to previous version
+PR="m10"
EXTRANATIVEPATH += "chrpath-native"
@@ -54,8 +50,6 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez',
PACKAGECONFIG[bluez] = "bluez='false',${BLUEZ}"
PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free"
-PYTHON2_SITEPACKAGES_DIR="${libdir}/python2.7/site-packages"
-
# Remove unneeded features. netfeed is needed by gpsmon
EXTRA_OESCONS = " \
sysroot=${STAGING_DIR_TARGET} \
@@ -153,8 +147,6 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
- install -d ${D}/${PYTHON2_SITEPACKAGES_DIR}/gps
- install -m 755 ${S}/gps/*.py ${D}/${PYTHON2_SITEPACKAGES_DIR}/gps
#support for systemd
install -d ${D}${systemd_unitdir}/system/
@@ -191,7 +183,7 @@ pkg_postrm_${PN}-conf() {
}
-PACKAGES =+ "libgps libgpsd gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils python-pygps-dbg python-pygps python3-pygps-dbg python3-pygps"
+PACKAGES =+ "libgps libgpsd gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils python3-pygps-dbg python3-pygps"
# PACKAGES =+ "${PN} ${PN}-dbg ${PN}-dev"
# File does not exist: ${libdir}/libQgpsmm.prl
@@ -232,12 +224,9 @@ FILES_gpspipe = "${bindir}/gpspipe"
SUMMARY_gps-utils = "Utils used for simulating, monitoring,... a GPS"
FILES_gps-utils = "${bindir}/*"
-RDEPENDS_gps-utils_mtbsp-at91 = "python-pygps"
RDEPENDS_gps-utils = "python3-pygps"
-SUMMARY_python-pygps = "Python bindings to gpsd"
SUMMARY_python3-pygps = "Python bindings to gpsd"
-FILES_python-pygps = "${PYTHON2_SITEPACKAGES_DIR}/*"
FILES_python3-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
RDEPENDS_python3-pygps = " \
python3-core \
@@ -248,15 +237,6 @@ RDEPENDS_python3-pygps = " \
gpsd \
python3-json"
-RDEPENDS_python-pygps = " \
- python-core \
- python-io \
- python-threading \
- python-terminal \
- python-curses \
- gpsd \
- python-json"
-
RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"
RCONFLICTS_${PN} += "${PN}-systemd"