summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2015-10-21 15:58:43 -0500
committerJason Reiss <jreiss@multitech.com>2015-10-21 15:58:43 -0500
commiteb60c9c535be9a16e7f63084f23dd1b687f30ec3 (patch)
treef7e9f8bb6af048f00c14106b0c4ec1f80226459e
parent2fc8b56bf20c37791931f42359b8099b04808015 (diff)
parent345cfbb0c73f47dcbbe28d50edd8b15b9090a68f (diff)
downloadmeta-mlinux-eb60c9c535be9a16e7f63084f23dd1b687f30ec3.tar.gz
meta-mlinux-eb60c9c535be9a16e7f63084f23dd1b687f30ec3.tar.bz2
meta-mlinux-eb60c9c535be9a16e7f63084f23dd1b687f30ec3.zip
Merge branch 'master' of git.multitech.net:meta-mlinux
Conflicts: recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-add-queue.patch
-rw-r--r--recipes-connectivity/lora/lora-network-server_0.0.8.bb (renamed from recipes-connectivity/lora/lora-network-server_0.0.7.bb)4
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-add-queue.patch4
-rw-r--r--recipes-connectivity/mosquitto/mosquitto_1.4.bb3
-rw-r--r--recipes-core/udev/udev-182/cellular_radios.rules3
-rw-r--r--recipes-support/multitech/libmts-io_0.1.bb4
5 files changed, 11 insertions, 7 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_0.0.7.bb b/recipes-connectivity/lora/lora-network-server_0.0.8.bb
index 6e6cc17..d2f55e8 100644
--- a/recipes-connectivity/lora/lora-network-server_0.0.7.bb
+++ b/recipes-connectivity/lora/lora-network-server_0.0.8.bb
@@ -13,8 +13,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${
file://lora-network-server.logrotate.conf \
"
-SRC_URI[md5sum] = "c22a75e96f22f55054796dfb04540d49"
-SRC_URI[sha256sum] = "27be3a327ba4c3b7eba4c4fe896de0a67f6a394257be0440ab4ea02238d8e097"
+SRC_URI[md5sum] = "8cb2686b427a32d53e301e87870b49cf"
+SRC_URI[sha256sum] = "be7de4463f17645882ed6194d9af2bc9a4608005635c8d31d5c5ec8bf552c73f"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-add-queue.patch b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-add-queue.patch
index bef41c9..cd9a727 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-add-queue.patch
+++ b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-add-queue.patch
@@ -159,8 +159,8 @@ index e20dfc1..4d0bb35 100644
}
MSG("\nINFO: End of downstream thread\n");
}
-
-diff --git a/gps_pkt_fwd/src/gps_pkt_fwd.c b/gps_pkt_fwd/src/gps_pkt_fwd.c
+
+iff --git a/gps_pkt_fwd/src/gps_pkt_fwd.c b/gps_pkt_fwd/src/gps_pkt_fwd.c
index 79f7584..3d1cbf8 100644
--- a/gps_pkt_fwd/src/gps_pkt_fwd.c
+++ b/gps_pkt_fwd/src/gps_pkt_fwd.c
diff --git a/recipes-connectivity/mosquitto/mosquitto_1.4.bb b/recipes-connectivity/mosquitto/mosquitto_1.4.bb
index 319ca49..3f035a7 100644
--- a/recipes-connectivity/mosquitto/mosquitto_1.4.bb
+++ b/recipes-connectivity/mosquitto/mosquitto_1.4.bb
@@ -5,7 +5,8 @@ SECTION = "console/network"
LICENSE = "EPL-1.0 EDL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=62ddc846179e908dc0c8efec4a42ef20"
-DEPENDS = "c-ares openssl"
+# util-linux is needed to provide libuuid dependancy
+DEPENDS = "c-ares openssl util-linux"
PR = "r2"
diff --git a/recipes-core/udev/udev-182/cellular_radios.rules b/recipes-core/udev/udev-182/cellular_radios.rules
index 81271ac..a3c06e4 100644
--- a/recipes-core/udev/udev-182/cellular_radios.rules
+++ b/recipes-core/udev/udev-182/cellular_radios.rules
@@ -43,5 +43,8 @@ ATTRS{idVendor}=="1199", ATTRS{idProduct}=="683c", ENV{ID_IFACE}=="04", SYMLINK+
ATTRS{idVendor}=="1199", ATTRS{idProduct}=="683c", ENV{ID_IFACE}=="05", SYMLINK+="modem_at2"
# EV2: ttyUSB0
ATTRS{idVendor}=="1199", ATTRS{idProduct}=="0028", ENV{ID_PORT}=="0", SYMLINK+="modem_at0"
+# LAT1, LEU1, LVW2: port 04 and port 05
+ATTRS{idVendor}=="1bc7", ATTRS{idProduct}=="1201", ENV{ID_IFACE}=="04", SYMLINK+="modem_at0"
+ATTRS{idVendor}=="1bc7", ATTRS{idProduct}=="1201", ENV{ID_IFACE}=="05", SYMLINK+="modem_at1"
LABEL="mlinux_end"
diff --git a/recipes-support/multitech/libmts-io_0.1.bb b/recipes-support/multitech/libmts-io_0.1.bb
index 9863237..b0a89d8 100644
--- a/recipes-support/multitech/libmts-io_0.1.bb
+++ b/recipes-support/multitech/libmts-io_0.1.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
DEPENDS = "libmts jsoncpp cmake-native cppunit"
BBCLASSEXTEND = "native"
-PR = "r1"
-SRCREV = "${PV}"
+PR = "r2"
+SRCREV = "c4d5c5e699743fa5a30f85f16edf2a3700099a78"
SRC_URI = "git://git.multitech.net/libmts-io;branch=master"
S = "${WORKDIR}/git"