summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Voloshynov <serhii.voloshynov@globallogic.com>2021-02-18 14:00:08 +0200
committerJohn Klug <john.klug@multitech.com>2021-06-22 09:25:54 -0500
commitcdd739a1828a88aa476e3b5cd438c124138f6e3f (patch)
tree419833b994f94e62a7185e9d63005224c09ceedd
parent7f1c813b73383d38c83d5052987e7d0846835bf1 (diff)
downloadmeta-mlinux-cdd739a1828a88aa476e3b5cd438c124138f6e3f.tar.gz
meta-mlinux-cdd739a1828a88aa476e3b5cd438c124138f6e3f.tar.bz2
meta-mlinux-cdd739a1828a88aa476e3b5cd438c124138f6e3f.zip
[MTX-3860]mPower R. Apr 2021: the MTCDT image does not include python-pygps
make gpsd recipe to generate python2 pygps package for Atmel based devices and python3 pygps package for TI based devices. later when python2 will be removed the commit should be reverted. FILES_python-pygps-dbg and FILES_python3-pygps-dbg were removed, because there is no site-packages/gps/.debug folder
-rw-r--r--recipes-navigation/gpsd/gpsd_3.20.bb27
1 files changed, 23 insertions, 4 deletions
diff --git a/recipes-navigation/gpsd/gpsd_3.20.bb b/recipes-navigation/gpsd/gpsd_3.20.bb
index b6a3773..2176924 100644
--- a/recipes-navigation/gpsd/gpsd_3.20.bb
+++ b/recipes-navigation/gpsd/gpsd_3.20.bb
@@ -4,7 +4,11 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=01764c35ae34d9521944bb6ab312af53"
DEPENDS = "dbus dbus-glib ncurses python3 libusb1 chrpath-replacement-native pps-tools"
PROVIDES = "virtual/gpsd"
-PR="m3"
+PR="m5"
+
+#TODO
+#the recipe generates python2 pygps package for Atmel based devices and python3 pygps package for TI based devices.
+#later when python2 will be removed the recipe should be returned to previous version
EXTRANATIVEPATH += "chrpath-native"
@@ -50,6 +54,8 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez',
PACKAGECONFIG[bluez] = "bluez='false',${BLUEZ}"
PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free"
+PYTHON2_SITEPACKAGES_DIR="${libdir}/python2.7/site-packages"
+
# Remove unneeded features. netfeed is needed by gpsmon
EXTRA_OESCONS = " \
sysroot=${STAGING_DIR_TARGET} \
@@ -147,6 +153,8 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
+ install -d ${D}/${PYTHON2_SITEPACKAGES_DIR}/gps
+ install -m 755 ${S}/gps/*.py ${D}/${PYTHON2_SITEPACKAGES_DIR}/gps
#support for systemd
install -d ${D}${systemd_unitdir}/system/
@@ -183,7 +191,7 @@ pkg_postrm_${PN}-conf() {
}
-PACKAGES =+ "libgps libgpsd python3-pygps-dbg python3-pygps gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils"
+PACKAGES =+ "libgps libgpsd gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils python-pygps-dbg python-pygps python3-pygps-dbg python3-pygps"
# PACKAGES =+ "${PN} ${PN}-dbg ${PN}-dev"
# File does not exist: ${libdir}/libQgpsmm.prl
@@ -196,7 +204,6 @@ FILES_${PN}-doc += "${docdir}"
FILES_${PN}-conf = "${sysconfdir}/default ${sysconfdir}/init.d"
-FILES_python3-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"
RDEPENDS_${PN}-conf = "gpsd-gpsctl bash"
@@ -225,11 +232,14 @@ FILES_gpspipe = "${bindir}/gpspipe"
SUMMARY_gps-utils = "Utils used for simulating, monitoring,... a GPS"
FILES_gps-utils = "${bindir}/*"
+RDEPENDS_gps-utils_mtbsp-at91 = "python-pygps"
RDEPENDS_gps-utils = "python3-pygps"
+SUMMARY_python-pygps = "Python bindings to gpsd"
SUMMARY_python3-pygps = "Python bindings to gpsd"
+FILES_python-pygps = "${PYTHON2_SITEPACKAGES_DIR}/*"
FILES_python3-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
-RDEPENDS_python-pygps = " \
+RDEPENDS_python3-pygps = " \
python3-core \
python3-io \
python3-threading \
@@ -238,6 +248,15 @@ RDEPENDS_python-pygps = " \
gpsd \
python3-json"
+RDEPENDS_python-pygps = " \
+ python-core \
+ python-io \
+ python-threading \
+ python-terminal \
+ python-curses \
+ gpsd \
+ python-json"
+
RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"
RCONFLICTS_${PN} += "${PN}-systemd"