summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-08-17 17:43:47 -0500
committerJohn Klug <john.klug@multitech.com>2020-11-12 09:25:39 -0600
commita77a2d3e9ac71ff38cf88df5834f51316e7ddfae (patch)
treee056d2a4662d6d5698d3e96ed9393a4417b4c0f2
parentf28a622111aab21a91d5b8122bb7e52568dd576c (diff)
downloadmeta-mlinux-a77a2d3e9ac71ff38cf88df5834f51316e7ddfae.tar.gz
meta-mlinux-a77a2d3e9ac71ff38cf88df5834f51316e7ddfae.tar.bz2
meta-mlinux-a77a2d3e9ac71ff38cf88df5834f51316e7ddfae.zip
Move registration check to chat_wrapper
-rw-r--r--recipes-connectivity/ppp/files/init.patch31
-rw-r--r--recipes-connectivity/ppp/ppp_%.bbappend6
2 files changed, 6 insertions, 31 deletions
diff --git a/recipes-connectivity/ppp/files/init.patch b/recipes-connectivity/ppp/files/init.patch
index e74e981..2d68474 100644
--- a/recipes-connectivity/ppp/files/init.patch
+++ b/recipes-connectivity/ppp/files/init.patch
@@ -1,31 +1,8 @@
-diff -Naru old/init new/init
---- old/init 2017-09-05 19:07:19.810885424 -0500
-+++ new/init 2017-09-05 19:08:05.106884083 -0500
-@@ -8,11 +8,29 @@
-
- test -x /usr/sbin/pppd -a -f /etc/ppp/ppp_on_boot || exit 0
- if [ -x /etc/ppp/ppp_on_boot ]; then RUNFILE=1; fi
--
-+: ${PPPTIMEOUT:=60}
-+logger timeout is $PPPTIMEOUT
-+[ -f /etc/default/ppp ] && . /etc/default/ppp
- case "$1" in
+diff -Naru orig/init new/init
+--- orig/init 2020-08-07 10:07:53.921964585 -0500
++++ new/init 2020-08-11 09:01:48.118064508 -0500
+@@ -16,6 +16,7 @@
start)
-+ t0=($(cat /proc/uptime))
-+ if (( CHECKREGISTRATION == 1 )) ; then while : ; do
-+ REG=$(/usr/bin/radio-query --netreg)
-+ [[ $REG == "REGISTERED" ]] && break
-+ t1=($(cat /proc/uptime))
-+ diff=$(awk "BEGIN{print int($t1-$t0)}")
-+ logger -s "Modem not ready. Waited $diff of $PPPTIMEOUT seconds"
-+ if ((diff > PPPTIMEOUT)) ; then
-+ logger -s "Timed out waiting for modem registration"
-+ exit 1
-+ fi
-+ sleep 1
-+ done ; fi
-+
-+ logger "Starting up PPP link: pppd"
echo -n "Starting up PPP link: pppd"
if [ "$RUNFILE" = "1" ]; then
+ logger "ppp_on_boot"
diff --git a/recipes-connectivity/ppp/ppp_%.bbappend b/recipes-connectivity/ppp/ppp_%.bbappend
index 55c47df..072fcd3 100644
--- a/recipes-connectivity/ppp/ppp_%.bbappend
+++ b/recipes-connectivity/ppp/ppp_%.bbappend
@@ -3,14 +3,12 @@ SRC_URI_append = "\
file://poff.patch;patchdir=.. \
file://default"
-PR = "r9"
+PR = "r10"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-FILES_${PN} += "/etc/default/ppp"
-
# AEP compatibility
-CONFFILES_${PN} += "${sysconfdir}/default/ppp ${sysconfdir}/init.d/ppp"
+CONFFILES_${PN} += "${sysconfdir}/init.d/ppp"
do_install_append() {
install -d -m 0755 ${D}/${sysconfdir}/default/