summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-08-24 08:52:40 -0500
committerJohn Klug <john.klug@multitech.com>2020-11-12 09:26:13 -0600
commit1561dbff0e684ec47df2f77128002c4df60950ed (patch)
tree3b880f8e19447621948e0cb49e36fadc47bb73f2
parent70f6edda828755fa3ab11f16b11378bff0b37599 (diff)
downloadmeta-mlinux-1561dbff0e684ec47df2f77128002c4df60950ed.tar.gz
meta-mlinux-1561dbff0e684ec47df2f77128002c4df60950ed.tar.bz2
meta-mlinux-1561dbff0e684ec47df2f77128002c4df60950ed.zip
Overlay is now used by MTR7 as well as MTCDT3
-rw-r--r--recipes-core/images/core-image-rorootfs-overlay-initramfs.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
new file mode 100644
index 0000000..47946c5
--- /dev/null
+++ b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
@@ -0,0 +1,23 @@
+# Simple initramfs image. Mostly used for live images.
+# Derived from https://github.com/cmhe/meta-readonly-rootfs-overlay
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), mounts the root fs \
+read only and uses a file system overlay for written data."
+
+PACKAGE_INSTALL = "initramfs-readonly-rootfs-overlay ${VIRTUAL-RUNTIME_base-utils} udev base-passwd gptfdisk ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "${PN}"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"