summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-08-23 18:11:19 -0500
committerJohn Klug <john.klug@multitech.com>2019-11-11 11:34:01 -0600
commita34d3bfffde71efb1588c146a07da239cb8e7cfb (patch)
treeeb60ba7bc0f5f45bbf07e46b6964bce8e043d98d
parentda5c6ce2c1096adb55599fcdc59cde1433a1245c (diff)
downloadmeta-mlinux-a34d3bfffde71efb1588c146a07da239cb8e7cfb.tar.gz
meta-mlinux-a34d3bfffde71efb1588c146a07da239cb8e7cfb.tar.bz2
meta-mlinux-a34d3bfffde71efb1588c146a07da239cb8e7cfb.zip
Missing $D in path for .profile
-rw-r--r--recipes-core/useradd/useradd.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-core/useradd/useradd.bb b/recipes-core/useradd/useradd.bb
index 7b70fec..d229a2f 100644
--- a/recipes-core/useradd/useradd.bb
+++ b/recipes-core/useradd/useradd.bb
@@ -1,7 +1,7 @@
SUMMARY = "Add mtadm user"
DESCRIPTION = "Add mtadm user for security purposes"
SECTION = "mtadm"
-PR = "r3"
+PR = "r4"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
@@ -46,12 +46,12 @@ FILES_${PN} = "/home/mtadm/.ssh"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
pkg_postinst_${PN} () {
- profile=/home/mtadm/.profile
+ profile=$D/home/mtadm/.profile
if ! grep 'sbin' ${profile} ; then
Sub='${PA'
Sub=${Sub}'TH}:/sbin:/usr/sbin'
- echo 'PATH='${Sub} >>/home/mtadm/.profile
- echo 'export PATH' >>/home/mtadm/.profile
+ echo 'PATH='${Sub} >>${profile}
+ echo 'export PATH' >>${profile}
fi
# If doing an update, we need to add mtadm to dialout.
# If the admin has been changed, then the user must