summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-10-17 15:29:40 -0500
committerJohn Klug <john.klug@multitech.com>2019-11-11 11:34:09 -0600
commit9cca1c01981a3f9153b2e8aaf72da82f7c08096c (patch)
tree7dce28dc4ea62d720ba3b99c4aefdf03c61d3bf8
parentf888298570ab64c2bae289b6602c963dc48c3b8c (diff)
downloadmeta-mlinux-9cca1c01981a3f9153b2e8aaf72da82f7c08096c.tar.gz
meta-mlinux-9cca1c01981a3f9153b2e8aaf72da82f7c08096c.tar.bz2
meta-mlinux-9cca1c01981a3f9153b2e8aaf72da82f7c08096c.zip
Need to set CFUN to 0 then CFUN to 1 to get modem to register after COPS startup
-rwxr-xr-xrecipes-core/multitech/config/chat_wrapper4
-rw-r--r--recipes-core/multitech/config_2.3.bb2
2 files changed, 5 insertions, 1 deletions
diff --git a/recipes-core/multitech/config/chat_wrapper b/recipes-core/multitech/config/chat_wrapper
index 3c05622..bb25d38 100755
--- a/recipes-core/multitech/config/chat_wrapper
+++ b/recipes-core/multitech/config/chat_wrapper
@@ -144,6 +144,10 @@ if [[ $MPDP != $PDP ]] || [[ $MAPN != $APN ]] || \
LOGMSG=$(/usr/bin/radio-cmd ${RADIOOPTION} -t10000 "${CMDSTR}" 2>&1)
${LOG} "Got response ${LOGMSG}"
/usr/bin/radio-cmd ${RADIOOPTION} -t10000 'AT+COPS=0'
+ sleep 1
+ /usr/bin/radio-cmd ${RADIOOPTION} -t10000 'AT+CFUN=0'
+ /usr/bin/radio-cmd ${RADIOOPTION} -t10000 'AT+CFUN=1'
+ sleep 1
${LOG} "New context is set. Wait up to $REGWAITTIME seconds to register"
# Wait for registration
uptime=$(cat /proc/uptime)
diff --git a/recipes-core/multitech/config_2.3.bb b/recipes-core/multitech/config_2.3.bb
index 9a4dabf..84721a7 100644
--- a/recipes-core/multitech/config_2.3.bb
+++ b/recipes-core/multitech/config_2.3.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
RDEPENDS_${PN} += "bash"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PACKAGE_ARCH = "all"
-PR = "r5"
+PR = "r6"
PACKAGES =+ "${PN}-mths"
inherit update-rc.d