summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Murphy <Patrick.Murphy@multitech.com>2020-06-11 12:24:21 -0500
committerJohn Klug <john.klug@multitech.com>2020-06-18 20:22:08 -0500
commit7a649703fa8f4941f010029a167dad245fe6c12b (patch)
tree6bfe6404a4a4558eb7f42059dd36296d305e35d4
parentcc23cc53628c2e900739e2a7dd7f0f784745c01c (diff)
downloadmeta-mlinux-7a649703fa8f4941f010029a167dad245fe6c12b.tar.gz
meta-mlinux-7a649703fa8f4941f010029a167dad245fe6c12b.tar.bz2
meta-mlinux-7a649703fa8f4941f010029a167dad245fe6c12b.zip
fixed update-rc.d error lighttpd
-rw-r--r--recipes-core/lighttpd/lighttpd/lighttpd.service11
-rw-r--r--recipes-core/lighttpd/lighttpd_1.4.48.bb13
-rw-r--r--recipes-core/multitech/commissioning_1.0.1.bb4
3 files changed, 23 insertions, 5 deletions
diff --git a/recipes-core/lighttpd/lighttpd/lighttpd.service b/recipes-core/lighttpd/lighttpd/lighttpd.service
new file mode 100644
index 0000000..535b1f4
--- /dev/null
+++ b/recipes-core/lighttpd/lighttpd/lighttpd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Lightning Fast Webserver With Light System Requirements
+After=network.target
+
+[Service]
+ExecStartPre=@SBINDIR@/lighttpd -t -f @SYSCONFDIR@/lighttpd.conf
+ExecStart=@SBINDIR@/lighttpd -D -f @SYSCONFDIR@/lighttpd.conf
+ExecReload=@BASE_BINDIR@/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-core/lighttpd/lighttpd_1.4.48.bb b/recipes-core/lighttpd/lighttpd_1.4.48.bb
index efb10df..38341d6 100644
--- a/recipes-core/lighttpd/lighttpd_1.4.48.bb
+++ b/recipes-core/lighttpd/lighttpd_1.4.48.bb
@@ -26,6 +26,7 @@ RDEPENDS_${PN} += " openssl"
SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.gz \
file://lighttpd.conf \
file://lighttpd.init \
+ file://lighttpd.service \
file://0001-lighttpd-pcre-use-pkg-config.patch;apply=true \
file://0004_fastcgi_env_with_unixsocket.patch;apply=true \
"
@@ -48,10 +49,10 @@ EXTRA_OECONF = " \
--disable-static \
"
-inherit useradd autotools pkgconfig gettext systemd
+inherit useradd update-rc.d autotools pkgconfig gettext systemd
INITSCRIPT_NAME = "lighttpd"
-INITSCRIPT_PARAMS = "defaults 60 40"
+INITSCRIPT_PARAMS = "defaults 70"
USERADD_PACKAGES = "${PN}"
GROUPADD_PARAM_${PN} = "--system --gid 667 www"
@@ -63,7 +64,13 @@ do_install_append() {
install -m 0755 --group www -d ${D}${localstatedir}/www
install -m 0755 ${WORKDIR}/lighttpd.init ${D}${sysconfdir}/init.d/lighttpd
install -m 0644 --group www ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
-
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@SBINDIR@,${sbindir},g' \
+ -e 's,@SYSCONFDIR@,${sysconfdir},g' \
+ -e 's,@BASE_BINDIR@,${base_bindir},g' \
+ ${D}${systemd_unitdir}/system/lighttpd.service
#For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
ln -sf ${localstatedir}/log ${D}/www/logs
ln -sf ${localstatedir}/tmp ${D}/www/var
diff --git a/recipes-core/multitech/commissioning_1.0.1.bb b/recipes-core/multitech/commissioning_1.0.1.bb
index 6fb0a12..8972cd5 100644
--- a/recipes-core/multitech/commissioning_1.0.1.bb
+++ b/recipes-core/multitech/commissioning_1.0.1.bb
@@ -12,9 +12,9 @@ PACKAGES =+ "${PN}-php-fpm"
INITSCRIPT_PACKAGES = "${PN} ${PN}-php-fpm"
INITSCRIPT_NAME_${PN} = "commission "
-INITSCRIPT_PARAMS_${PN} = "start 9 2 3 4 5 ."
+INITSCRIPT_PARAMS_${PN} = "start 09 2 3 4 5 ."
INITSCRIPT_NAME_${PN}-php-fpm = "commission-php-fpm"
-INITSCRIPT_PARAMS_${PN}-php-fpm = "start 9 2 3 4 5 ."
+INITSCRIPT_PARAMS_${PN}-php-fpm = "start 09 2 3 4 5 ."
PR = "r1"
SRCREV = "${PV}"