summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-07-02 17:00:23 -0500
committerJohn Klug <john.klug@multitech.com>2018-07-02 17:00:23 -0500
commit2089e3b08f775687c2827b790f5d1cf27c71f064 (patch)
tree2bbc597f7aeb7d46431af1c528e40d7d7c75a1eb
parenta52ec37d24f6d24b7bb3fcf64e711b197eebf857 (diff)
downloadmeta-mlinux-2089e3b08f775687c2827b790f5d1cf27c71f064.tar.gz
meta-mlinux-2089e3b08f775687c2827b790f5d1cf27c71f064.tar.bz2
meta-mlinux-2089e3b08f775687c2827b790f5d1cf27c71f064.zip
LoRa fix for reading FPGA revision in AEP
-rw-r--r--recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb14
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb12
2 files changed, 16 insertions, 10 deletions
diff --git a/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
index eda0247..3eb9ddc 100644
--- a/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
+++ b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
@@ -5,16 +5,19 @@ SECTION = "console/utils"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://mlinux4/LICENSE.TXT;md5=86776875df1423114abfcec938f3e565"
DEPENDS = ""
-PR = "r3"
+# Source revision
+PSR = "r1"
+# Recipe revision
+PR = "r4"
SRCREV = "v${PV}"
-SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}.tar.gz \
+SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}-${PSR}.tar.gz \
file://config.json \
file://config_64ch.json \
"
-SRC_URI[md5sum] = "58d8c18e54ebd84dbd89d70e0640da16"
-SRC_URI[sha256sum] = "899441f301d50ae9de9efe6ac6d01e6557e952eedf47fc055c782671ab81dd1b"
+SRC_URI[md5sum] = "ee5b1f030d513e59248c4146d5629a18"
+SRC_URI[sha256sum] = "a2154e9e79f713fef8ec6db7477c4df16aaae4537cccd65489bd28f75197ec5a"
S = "${WORKDIR}"
@@ -29,7 +32,8 @@ do_install() {
install -m 0644 mlinux4/libsx1301ar/* ${D}${includedir}/lora
install -d ${D}/sbin
- install -m 0755 mlinux4/gateway-utils-geo/fpga_flash_loader ${D}/sbin/sem-fpga-loader
+ # Set UID to be able to read FPGA revision as non-root.
+ install -m 04755 mlinux4/gateway-utils-geo/fpga_flash_loader ${D}/sbin/sem-fpga-loader
install -d ${D}/opt/lora/
install -d ${D}/opt/lora/gateway-utils-geo
diff --git a/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
index dbf7094..8f66008 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
@@ -6,11 +6,14 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://mlinux4/LICENSE.TXT;md5=86776875df1423114abfcec938f3e565"
DEPENDS ?= "lora-gateway-geolocation logrotate"
RDEPENDS_${PN} += "bash"
-PR = "r2"
+# Source revision
+PSR = "r1"
+# Recipe revision
+PR = "r3"
SRCREV = "v${PV}"
-SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}.tar.gz \
+SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}-${PSR}.tar.gz \
file://lora-packet-forwarder-geolocation.logrotate.conf \
file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_full_diversity_EU868 \
file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_full_diversity_JP920 \
@@ -24,9 +27,8 @@ SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm9
file://global_conf.json.MTAC_LORA_2_1_test_single_antenna_64ch_64x1_EU868 \
file://global_conf.json.MTAC_LORA_2_1_test_single_antenna_64ch_8x8_EU868 \
"
-
-SRC_URI[md5sum] = "58d8c18e54ebd84dbd89d70e0640da16"
-SRC_URI[sha256sum] = "899441f301d50ae9de9efe6ac6d01e6557e952eedf47fc055c782671ab81dd1b"
+SRC_URI[md5sum] = "ee5b1f030d513e59248c4146d5629a18"
+SRC_URI[sha256sum] = "a2154e9e79f713fef8ec6db7477c4df16aaae4537cccd65489bd28f75197ec5a"
S = "${WORKDIR}"
B = "${S}"