summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2018-07-17 14:06:21 -0500
committerJason Reiss <jreiss@multitech.com>2018-07-17 14:06:21 -0500
commit1bf218bf284540382831eaf4e347e5e8e72cfbca (patch)
treefd430ea0bebd883dbe8dd8c809f6a9454fc36d56
parente8f1fabebe0992936496bff1910c1df4f2fe20b8 (diff)
downloadmeta-mlinux-1bf218bf284540382831eaf4e347e5e8e72cfbca.tar.gz
meta-mlinux-1bf218bf284540382831eaf4e347e5e8e72cfbca.tar.bz2
meta-mlinux-1bf218bf284540382831eaf4e347e5e8e72cfbca.zip
lora: update spectral scan to skip FPGA reset for v31
-rw-r--r--recipes-connectivity/lora/lora-gateway/lora-gateway-spectral-scan-skip-fpga-reset.patch14
-rw-r--r--recipes-connectivity/lora/lora-gateway_5.0.1.bb3
2 files changed, 16 insertions, 1 deletions
diff --git a/recipes-connectivity/lora/lora-gateway/lora-gateway-spectral-scan-skip-fpga-reset.patch b/recipes-connectivity/lora/lora-gateway/lora-gateway-spectral-scan-skip-fpga-reset.patch
new file mode 100644
index 0000000..6e64ea6
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway/lora-gateway-spectral-scan-skip-fpga-reset.patch
@@ -0,0 +1,14 @@
+diff --git a/util_spectral_scan/src/util_spectral_scan.c b/util_spectral_scan/src/util_spectral_scan.c
+index d2aecda..f070f4b 100644
+--- a/util_spectral_scan/src/util_spectral_scan.c
++++ b/util_spectral_scan/src/util_spectral_scan.c
+@@ -264,7 +264,7 @@ int main( int argc, char ** argv )
+ printf("ERROR: Failed to disconnect from FPGA\n");
+ return EXIT_FAILURE;
+ }
+- x = lgw_connect(false, LGW_DEFAULT_NOTCH_FREQ); /* FPGA reset/configure */
++ x = lgw_connect(true, LGW_DEFAULT_NOTCH_FREQ); /* FPGA reset/configure */
+ if(x != 0) {
+ printf("ERROR: Failed to connect to FPGA\n");
+ return EXIT_FAILURE;
+
diff --git a/recipes-connectivity/lora/lora-gateway_5.0.1.bb b/recipes-connectivity/lora/lora-gateway_5.0.1.bb
index 9a471ac..5a7c758 100644
--- a/recipes-connectivity/lora/lora-gateway_5.0.1.bb
+++ b/recipes-connectivity/lora/lora-gateway_5.0.1.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
DEPENDS = ""
-PR = "r10"
+PR = "r11"
SRCREV = "v${PV}"
SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
@@ -16,6 +16,7 @@ SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
file://ln-lora-spi-dev.sh \
file://lora-gateway-change-util-tx-continuous-clksrc.patch \
file://lora-gateway-v28-skip-IQ-invert.patch \
+ file://lora-gateway-spectral-scan-skip-fpga-reset.patch \
"
SRC_URI[md5sum] = "9e06a3733a9fea39a3d61f77b412badf"