summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2019-03-13 11:29:21 -0500
committerJason Reiss <jreiss@multitech.com>2019-03-13 11:29:21 -0500
commiteff79c798ffc180ce23a5a6447fe1928e2853bca (patch)
tree565f5f4e912297db169f3b29e6a234c4a7ab8f86
parentbdbbbe60d5e9b9e23da8d8639e6941370009dab2 (diff)
parent0350271276e473b38d29706f2df5d645fb7ed25f (diff)
downloadmeta-mlinux-eff79c798ffc180ce23a5a6447fe1928e2853bca.tar.gz
meta-mlinux-eff79c798ffc180ce23a5a6447fe1928e2853bca.tar.bz2
meta-mlinux-eff79c798ffc180ce23a5a6447fe1928e2853bca.zip
Merge branch 'master' of gitlab.multitech.net:mirrors/meta-mlinux
-rw-r--r--recipes-support/multitech/libmts-io_1.0.15.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-support/multitech/libmts-io_1.0.15.bb b/recipes-support/multitech/libmts-io_1.0.15.bb
new file mode 100644
index 0000000..34115be
--- /dev/null
+++ b/recipes-support/multitech/libmts-io_1.0.15.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "MultiTech IO C++ Library"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "libmts jsoncpp cmake-native cppunit"
+BBCLASSEXTEND = "native"
+
+PR = "r0"
+SRCREV = "${PV}"
+SRC_URI = "git://git.multitech.net/libmts-io;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+# build and run tests for native recipe
+do_compile_append_virtclass-native() {
+ cd test
+ cmake .
+ oe_runmake
+ ./TestRunnerClient
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+