summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2019-01-11 15:16:13 -0600
committerJason Reiss <jreiss@multitech.com>2019-01-11 15:16:13 -0600
commite152c52b6e6458c513db41547982b2591f4b8003 (patch)
tree5498a25c1d6bfe94b2c6422fbfa5c840fdeb7548
parent9dad0b7171d9a6dda4f4209c9d7b4fd164f9e391 (diff)
downloadmeta-mlinux-e152c52b6e6458c513db41547982b2591f4b8003.tar.gz
meta-mlinux-e152c52b6e6458c513db41547982b2591f4b8003.tar.bz2
meta-mlinux-e152c52b6e6458c513db41547982b2591f4b8003.zip
lora: add RU864 packet forwarder configs"
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc02
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0191
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic197
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb6
4 files changed, 394 insertions, 2 deletions
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0
index 0046e6f..f7c51d9 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0
+++ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0
@@ -183,7 +183,7 @@
"forward_crc_disabled": false,
"forward_crc_error": false,
"forward_crc_valid": true,
- "gateway_ID": "AA555A0000000000",
+ "gateway_ID": "<WILL-BE-REPLACED-WITH-LORA-EUI>",
"keepalive_interval": 10,
"push_timeout_ms": 100,
"serv_port_down": 1680,
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0 b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0
new file mode 100644
index 0000000..04d1ec9
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0
@@ -0,0 +1,191 @@
+{
+ "SX1301_conf": {
+ "antenna_gain": 0,
+ "chan_FSK": {
+ "bandwidth": 125000,
+ "datarate": 50000,
+ "freq_deviation": 25000,
+ "enable": true,
+ "if": 0,
+ "radio": 0
+ },
+ "chan_Lora_std": {
+ "bandwidth": 250000,
+ "enable": true,
+ "if": -200000,
+ "radio": 0,
+ "spread_factor": 7
+ },
+ "chan_multiSF_0": {
+ "enable": true,
+ "if": -400000,
+ "radio": 0
+ },
+ "chan_multiSF_1": {
+ "enable": true,
+ "if": -200000,
+ "radio": 0
+ },
+ "chan_multiSF_2": {
+ "enable": true,
+ "if": 0,
+ "radio": 0
+ },
+ "chan_multiSF_3": {
+ "enable": true,
+ "if": -400000,
+ "radio": 1
+ },
+ "chan_multiSF_4": {
+ "enable": true,
+ "if": -200000,
+ "radio": 1
+ },
+ "chan_multiSF_5": {
+ "enable": true,
+ "if": 0,
+ "radio": 1
+ },
+ "chan_multiSF_6": {
+ "enable": true,
+ "if": 200000,
+ "radio": 1
+ },
+ "chan_multiSF_7": {
+ "enable": false,
+ "if": 400000,
+ "radio": 0
+ },
+ "clksrc": 0,
+ "lbt_cfg": {
+ "enable": false,
+ "rssi_target": 160
+ },
+ "lorawan_public": true,
+ "radio_0": {
+ "enable": true,
+ "freq": 869100000,
+ "rssi_offset": -162,
+ "tx_enable": true,
+ "tx_freq_max": 870000000,
+ "tx_freq_min": 864000000,
+ "type": "SX1257"
+ },
+ "radio_1": {
+ "enable": true,
+ "freq": 868100000,
+ "rssi_offset": -162,
+ "tx_enable": false,
+ "type": "SX1257"
+ },
+ "tx_lut_0": {
+ "dig_gain": 0,
+ "mix_gain": 11,
+ "pa_gain": 0,
+ "rf_power": -6
+ },
+ "tx_lut_1": {
+ "dig_gain": 0,
+ "mix_gain": 13,
+ "pa_gain": 0,
+ "rf_power": -3
+ },
+ "tx_lut_10": {
+ "dig_gain": 0,
+ "mix_gain": 15,
+ "pa_gain": 2,
+ "rf_power": 16
+ },
+ "tx_lut_11": {
+ "dig_gain": 0,
+ "mix_gain": 10,
+ "pa_gain": 3,
+ "rf_power": 20
+ },
+ "tx_lut_12": {
+ "dig_gain": 0,
+ "mix_gain": 12,
+ "pa_gain": 3,
+ "rf_power": 23
+ },
+ "tx_lut_13": {
+ "dig_gain": 0,
+ "mix_gain": 13,
+ "pa_gain": 3,
+ "rf_power": 25
+ },
+ "tx_lut_14": {
+ "dig_gain": 0,
+ "mix_gain": 15,
+ "pa_gain": 3,
+ "rf_power": 26
+ },
+ "tx_lut_15": {
+ "dig_gain": 0,
+ "mix_gain": 15,
+ "pa_gain": 3,
+ "rf_power": 27
+ },
+ "tx_lut_2": {
+ "dig_gain": 0,
+ "mix_gain": 9,
+ "pa_gain": 1,
+ "rf_power": 0
+ },
+ "tx_lut_3": {
+ "dig_gain": 0,
+ "mix_gain": 10,
+ "pa_gain": 1,
+ "rf_power": 3
+ },
+ "tx_lut_4": {
+ "dig_gain": 0,
+ "mix_gain": 12,
+ "pa_gain": 1,
+ "rf_power": 6
+ },
+ "tx_lut_5": {
+ "dig_gain": 0,
+ "mix_gain": 10,
+ "pa_gain": 2,
+ "rf_power": 10
+ },
+ "tx_lut_6": {
+ "dig_gain": 0,
+ "mix_gain": 11,
+ "pa_gain": 2,
+ "rf_power": 11
+ },
+ "tx_lut_7": {
+ "dig_gain": 0,
+ "mix_gain": 11,
+ "pa_gain": 2,
+ "rf_power": 12
+ },
+ "tx_lut_8": {
+ "dig_gain": 2,
+ "mix_gain": 12,
+ "pa_gain": 2,
+ "rf_power": 13
+ },
+ "tx_lut_9": {
+ "dig_gain": 0,
+ "mix_gain": 13,
+ "pa_gain": 2,
+ "rf_power": 14
+ }
+ },
+ "gateway_conf": {
+ "forward_crc_disabled": false,
+ "forward_crc_error": true,
+ "forward_crc_valid": true,
+ "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
+ "keepalive_interval": 10,
+ "push_timeout_ms": 100,
+ "serv_port_down": 20000,
+ "serv_port_up": 20000,
+ "server_address": "52.3.215.147",
+ "stat_interval": 30,
+ "autoquit_threshold": 60
+ }
+}
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic
new file mode 100644
index 0000000..a0636a7
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic
@@ -0,0 +1,197 @@
+{
+ "SX1301_conf": {
+ "lorawan_public": true,
+ "clksrc": 0,
+ "lbt_cfg": {
+ "enable": false,
+ "rssi_target": 160,
+ "nb_channel": 1,
+ "start_freq": 869525000,
+ "scan_time_us": 5000,
+ "tx_delay_1ch_us": 4000000,
+ "tx_delay_2ch_us": 4000000
+ },
+ "antenna_gain": 0,
+ "radio_0": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 869100000,
+ "rssi_offset": -162,
+ "tx_enable": true,
+ "tx_freq_min": 864000000,
+ "tx_freq_max": 870000000
+ },
+ "radio_1": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 868100000,
+ "rssi_offset": -162,
+ "tx_enable": false
+ },
+ "chan_multiSF_0": {
+ "enable": true,
+ "radio": 0,
+ "if": -400000
+ },
+ "chan_multiSF_1": {
+ "enable": true,
+ "radio": 0,
+ "if": -200000
+ },
+ "chan_multiSF_2": {
+ "enable": true,
+ "radio": 0,
+ "if": 0
+ },
+ "chan_multiSF_3": {
+ "enable": true,
+ "radio": 1,
+ "if": -400000
+ },
+ "chan_multiSF_4": {
+ "enable": true,
+ "radio": 1,
+ "if": -200000
+ },
+ "chan_multiSF_5": {
+ "enable": true,
+ "radio": 1,
+ "if": 0
+ },
+ "chan_multiSF_6": {
+ "enable": true,
+ "radio": 1,
+ "if": 200000
+ },
+ "chan_multiSF_7": {
+ "enable": true,
+ "radio": 1,
+ "if": 400000
+ },
+ "chan_Lora_std": {
+ "enable": true,
+ "radio": 0,
+ "if": -200000,
+ "bandwidth": 250000,
+ "spread_factor": 7
+ },
+ "chan_FSK": {
+ "enable": true,
+ "radio": 1,
+ "if": 0,
+ "bandwidth": 125000,
+ "datarate": 50000
+ },
+ "tx_lut_0": {
+ "pa_gain": 0,
+ "mix_gain": 9,
+ "rf_power": -6,
+ "dig_gain": 1
+ },
+ "tx_lut_1": {
+ "pa_gain": 0,
+ "mix_gain": 12,
+ "rf_power": -3,
+ "dig_gain": 1
+ },
+ "tx_lut_2": {
+ "pa_gain": 1,
+ "mix_gain": 8,
+ "rf_power": 0,
+ "dig_gain": 2
+ },
+ "tx_lut_3": {
+ "pa_gain": 1,
+ "mix_gain": 11,
+ "rf_power": 3,
+ "dig_gain": 3
+ },
+ "tx_lut_4": {
+ "pa_gain": 1,
+ "mix_gain": 10,
+ "rf_power": 6,
+ "dig_gain": 0
+ },
+ "tx_lut_5": {
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 10,
+ "dig_gain": 3
+ },
+ "tx_lut_6": {
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 11,
+ "dig_gain": 1
+ },
+ "tx_lut_7": {
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 12,
+ "dig_gain": 0
+ },
+ "tx_lut_8": {
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 13,
+ "dig_gain": 2
+ },
+ "tx_lut_9": {
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 14,
+ "dig_gain": 1
+ },
+ "tx_lut_10": {
+ "pa_gain": 2,
+ "mix_gain": 12,
+ "rf_power": 16,
+ "dig_gain": 0
+ },
+ "tx_lut_11": {
+ "pa_gain": 3,
+ "mix_gain": 10,
+ "rf_power": 20,
+ "dig_gain": 3
+ },
+ "tx_lut_12": {
+ "pa_gain": 3,
+ "mix_gain": 9,
+ "rf_power": 23,
+ "dig_gain": 0
+ },
+ "tx_lut_13": {
+ "pa_gain": 3,
+ "mix_gain": 12,
+ "rf_power": 25,
+ "dig_gain": 2
+ },
+ "tx_lut_14": {
+ "pa_gain": 3,
+ "mix_gain": 13,
+ "rf_power": 26,
+ "dig_gain": 0
+ },
+ "tx_lut_15": {
+ "pa_gain": 3,
+ "mix_gain": 15,
+ "rf_power": 27,
+ "dig_gain": 2
+ }
+ },
+ "gateway_conf": {
+ "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
+ "server_address": "52.3.215.147",
+ "serv_port_up": 20000,
+ "serv_port_down": 20000,
+ "keepalive_interval": 10,
+ "stat_interval": 30,
+ "push_timeout_ms": 100,
+ "forward_crc_valid": true,
+ "forward_crc_error": true,
+ "forward_crc_disabled": false,
+ "synch_word": 52,
+ "autoquit_threshold": 60
+ }
+}
+
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
index e3f59ef..282d09e 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
@@ -7,7 +7,7 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
DEPENDS = "lora-gateway logrotate lora-logging"
RDEPENDS_${PN} += "bash"
-PR = "r15"
+PR = "r16"
SRCREV = "v${PV}"
@@ -25,6 +25,7 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://global_conf.json.3.0.0.MTAC_LORA_1_5.KR920-LBT.basic.clksrc0 \
file://global_conf.json.3.0.0.MTAC_LORA_1_5.IN865.basic.clksrc0 \
file://global_conf.json.3.0.0.MTAC_LORA_1_5.AU915.basic.clksrc0 \
+ file://global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0 \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.EU868.basic \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.US915.basic \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.AU915.basic \
@@ -32,6 +33,7 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.AS923-LBT.basic \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.IN865.basic \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.KR920-LBT.basic \
+ file://global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic \
file://local_conf.json \
file://lora-packet-forwarder-add-spi-dev-path.patch \
file://lora-packet-forwarder-remove-jit-power-check.patch \
@@ -77,6 +79,7 @@ do_install_append_mtcdt() {
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0.EU868
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5.EU868
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5.RU864
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.US915.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0.US915
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.US915.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5.US915
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.AU915.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5.AU915
@@ -88,6 +91,7 @@ do_install_append_mtcdt() {
do_install_append_mtcap() {
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.EU868.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.EU868
+ install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.RU864
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.US915.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.US915
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.AU915.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.AU915
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.AS923.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.AS923