summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2017-04-21 15:08:25 -0500
committerJohn Klug <john.klug@multitech.com>2017-07-05 10:55:40 -0500
commitbf7fb28eed3e8646d01c3dd1d2a1f50dd05feeab (patch)
treed1b44fbef0c32974235951b4458567b4913b22bd
parent25f62e364f865a46e44dae71ea94cded96047897 (diff)
downloadmeta-mlinux-bf7fb28eed3e8646d01c3dd1d2a1f50dd05feeab.tar.gz
meta-mlinux-bf7fb28eed3e8646d01c3dd1d2a1f50dd05feeab.tar.bz2
meta-mlinux-bf7fb28eed3e8646d01c3dd1d2a1f50dd05feeab.zip
lora: update network server, loragw, and packet-forwarder versions
-rw-r--r--recipes-connectivity/lora/lora-gateway/lora-gateway-add-fpga-version-28-31-33.patch22
-rw-r--r--recipes-connectivity/lora/lora-gateway/lora-gateway-v28-skip-IQ-invert.patch24
-rw-r--r--recipes-connectivity/lora/lora-gateway_4.1.3.bb (renamed from recipes-connectivity/lora/lora-gateway_4.0.1.bb)6
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.29.bb (renamed from recipes-connectivity/lora/lora-network-server_1.0.26.bb)4
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.1.0.bb (renamed from recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb)0
5 files changed, 49 insertions, 7 deletions
diff --git a/recipes-connectivity/lora/lora-gateway/lora-gateway-add-fpga-version-28-31-33.patch b/recipes-connectivity/lora/lora-gateway/lora-gateway-add-fpga-version-28-31-33.patch
index 1950573..7e73263 100644
--- a/recipes-connectivity/lora/lora-gateway/lora-gateway-add-fpga-version-28-31-33.patch
+++ b/recipes-connectivity/lora/lora-gateway/lora-gateway-add-fpga-version-28-31-33.patch
@@ -1,5 +1,5 @@
diff --git a/libloragw/src/loragw_reg.c b/libloragw/src/loragw_reg.c
-index 7e396bc..e71e695 100644
+index 7e396bc..478f46a 100644
--- a/libloragw/src/loragw_reg.c
+++ b/libloragw/src/loragw_reg.c
@@ -48,7 +48,7 @@ Maintainer: Sylvain Miermont
@@ -9,4 +9,22 @@ index 7e396bc..e71e695 100644
-const uint8_t FPGA_VERSION[] = { 31, 33 }; /* several versions could be supported */
+const uint8_t FPGA_VERSION[] = { 28, 31, 33 }; /* several versions could be supported */
- /* \ No newline at end of file
+ /*
+ auto generated register mapping for C code : 11-Jul-2013 13:20:40
+@@ -415,6 +415,16 @@ bool check_fpga_version(uint8_t version) {
+ return false;
+ }
+
++uint8_t read_fpga_version() {
++ uint8_t u = 0;
++ uint8_t spi_stat = lgw_spi_r(lgw_spi_target, LGW_SPI_MUX_MODE1, LGW_SPI_MUX_TARGET_FPGA, loregs[LGW_VERSION].addr, &u);
++ if (spi_stat != LGW_SPI_SUCCESS) {
++ DEBUG_MSG("ERROR READING VERSION REGISTER\n");
++ return LGW_REG_ERROR;
++ }
++ return u;
++}
++
+ /* ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ */
+
+ int reg_w_align32(void *spi_target, uint8_t spi_mux_mode, uint8_t spi_mux_target, struct lgw_reg_s r, int32_t reg_value) {
diff --git a/recipes-connectivity/lora/lora-gateway/lora-gateway-v28-skip-IQ-invert.patch b/recipes-connectivity/lora/lora-gateway/lora-gateway-v28-skip-IQ-invert.patch
new file mode 100644
index 0000000..25065df
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway/lora-gateway-v28-skip-IQ-invert.patch
@@ -0,0 +1,24 @@
+diff --git a/libloragw/src/loragw_fpga.c b/libloragw/src/loragw_fpga.c
+index fa83a2a..7e667e3 100644
+--- a/libloragw/src/loragw_fpga.c
++++ b/libloragw/src/loragw_fpga.c
+@@ -144,11 +144,14 @@ int lgw_fpga_configure(uint32_t tx_notch_freq) {
+ return LGW_REG_ERROR;
+ }
+
+- /* Required for Semtech AP2 reference design */
+- x = lgw_fpga_reg_w(LGW_FPGA_CTRL_INVERT_IQ, 1);
+- if (x != LGW_REG_SUCCESS) {
+- DEBUG_MSG("ERROR: Failed to configure FPGA polarity\n");
+- return LGW_REG_ERROR;
++
++ if (read_fpga_version() > 28) {
++ /* Required for Semtech AP2 reference design and AP1.5 > v28 */
++ x = lgw_fpga_reg_w(LGW_FPGA_CTRL_INVERT_IQ, 1);
++ if (x != LGW_REG_SUCCESS) {
++ DEBUG_MSG("ERROR: Failed to configure FPGA polarity\n");
++ return LGW_REG_ERROR;
++ }
+ }
+
+ /* Configure TX notch filter */
diff --git a/recipes-connectivity/lora/lora-gateway_4.0.1.bb b/recipes-connectivity/lora/lora-gateway_4.1.3.bb
index 8f66aa0..6c3214b 100644
--- a/recipes-connectivity/lora/lora-gateway_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-gateway_4.1.3.bb
@@ -6,16 +6,16 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
DEPENDS = ""
-PR = "r9"
+PR = "r10"
SRCREV = "v${PV}"
SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
- file://lora-gateway-add-fpga-version-28.patch \
+ file://lora-gateway-add-fpga-version-28-31-33.patch \
file://library_4.0.cfg \
file://lora-gateway-add-spi-path-function.patch \
file://ln-lora-spi-dev.sh \
file://lora-gateway-change-util-tx-continuous-clksrc.patch \
- file://lora-gateway-semtech-sf12.patch \
+ file://lora-gateway-v28-skip-IQ-invert.patch \
"
SRC_URI[md5sum] = "9e06a3733a9fea39a3d61f77b412badf"
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.26.bb b/recipes-connectivity/lora/lora-network-server_1.0.29.bb
index 7bde556..2afeec2 100644
--- a/recipes-connectivity/lora/lora-network-server_1.0.26.bb
+++ b/recipes-connectivity/lora/lora-network-server_1.0.29.bb
@@ -13,8 +13,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${
file://lora-network-server.logrotate.conf \
"
-SRC_URI[md5sum] = "2c49e1b7e399cac2382fb73537da215c"
-SRC_URI[sha256sum] = "a287d594b59a041877ee2db698383a77a36be348ffe111e2b6c93e1ce93e7ca3"
+SRC_URI[md5sum] = "440097dbaf9fa85932b126d61455f797"
+SRC_URI[sha256sum] = "8c1b825f4d0bae5f41aa38eb5c3df2797d6d279c89ebe9a75a0a7161e700f4f2"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.1.0.bb
index 98e1973..98e1973 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.1.0.bb