summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2017-02-21 09:16:28 -0600
committerJason Reiss <jreiss@multitech.com>2017-02-21 09:16:28 -0600
commit8b227193f247dc0c7c310fd32099b3864d2806b0 (patch)
tree573d8e733e577ed6b6160a226cb8327223a7c6db
parentca0ba060fb487bac8e83047de985769eb66c9bdd (diff)
downloadmeta-mlinux-8b227193f247dc0c7c310fd32099b3864d2806b0.tar.gz
meta-mlinux-8b227193f247dc0c7c310fd32099b3864d2806b0.tar.bz2
meta-mlinux-8b227193f247dc0c7c310fd32099b3864d2806b0.zip
lora: update LNS to 1.0.24
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.24.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.24.bb b/recipes-connectivity/lora/lora-network-server_1.0.24.bb
new file mode 100644
index 0000000..c3076cb
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_1.0.24.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r1"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "073428947bdaab6e0db2b9510e997a97"
+SRC_URI[sha256sum] = "ed41c09918743d15c6fcf85387dbed167a2df4e39557a8f85f6651e52480bd77"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"