summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2017-02-06 13:06:15 -0600
committerJason Reiss <jreiss@multitech.com>2017-02-06 13:06:15 -0600
commit9132e5ab0f95d0664307108464bee2405f29bf36 (patch)
treeb7feb66eda915b12d86b3dc02d7ada08439d1617
parent6bdd50dcac87ffcc6e62bf429cd7162208fdbdf3 (diff)
downloadmeta-mlinux-9132e5ab0f95d0664307108464bee2405f29bf36.tar.gz
meta-mlinux-9132e5ab0f95d0664307108464bee2405f29bf36.tar.bz2
meta-mlinux-9132e5ab0f95d0664307108464bee2405f29bf36.zip
lora: update lora-network-server
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.23.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.23.bb b/recipes-connectivity/lora/lora-network-server_1.0.23.bb
new file mode 100644
index 0000000..addd238
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_1.0.23.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r1"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "453788c7a3b52aca771e9cf3b26d49a2"
+SRC_URI[sha256sum] = "1a9a1c886b42a09e640fd85a87897052986b510bbddec0b9597575980e880d86"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"