summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2017-02-21 15:24:33 -0600
committerJason Reiss <jreiss@multitech.com>2017-02-21 15:24:33 -0600
commita7cc6fd99a95df79caa76be20fef7a0b50edaae6 (patch)
treef16dac038845668958538abd3ce19148a5c14f55
parent8b227193f247dc0c7c310fd32099b3864d2806b0 (diff)
downloadmeta-mlinux-a7cc6fd99a95df79caa76be20fef7a0b50edaae6.tar.gz
meta-mlinux-a7cc6fd99a95df79caa76be20fef7a0b50edaae6.tar.bz2
meta-mlinux-a7cc6fd99a95df79caa76be20fef7a0b50edaae6.zip
lora: add semtech patch for gateway tx on SF12, remove old LNS recipes
-rw-r--r--recipes-connectivity/lora/lora-gateway/lora-gateway-semtech-sf12.patch16
-rw-r--r--recipes-connectivity/lora/lora-gateway_4.0.1.bb1
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.22.bb49
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.23.bb49
4 files changed, 17 insertions, 98 deletions
diff --git a/recipes-connectivity/lora/lora-gateway/lora-gateway-semtech-sf12.patch b/recipes-connectivity/lora/lora-gateway/lora-gateway-semtech-sf12.patch
new file mode 100644
index 0000000..7ea09d2
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway/lora-gateway-semtech-sf12.patch
@@ -0,0 +1,16 @@
+t a/libloragw/src/loragw_hal.c b/libloragw/src/loragw_hal.c
+index 7271eac..e5770df 100644
+--- a/libloragw/src/loragw_hal.c
++++ b/libloragw/src/loragw_hal.c
+@@ -305,6 +305,11 @@ void lgw_constant_adjust(void) {
+ // lgw_reg_w(LGW_MBWSSF_TRACKING_INTEGRAL,0); /* default 0 */
+ // lgw_reg_w(LGW_MBWSSF_AGC_FREEZE_ON_DETECT,1); /* default 1 */
+
++ /* Improvement of reference clock frequency error tolerance */
++ lgw_reg_w(LGW_ADJUST_MODEM_START_OFFSET_RDX4, 1); /* default 0 */
++ lgw_reg_w(LGW_ADJUST_MODEM_START_OFFSET_SF12_RDX4, 4094); /* default 4092 */
++ lgw_reg_w(LGW_CORR_MAC_GAIN, 7); /* default 5 */
++
+ /* FSK datapath setup */
+ lgw_reg_w(LGW_FSK_RX_INVERT,1); /* default 0 */
+ lgw_reg_w(LGW_FSK_MODEM_INVERT_IQ,1); /* default 0 */
diff --git a/recipes-connectivity/lora/lora-gateway_4.0.1.bb b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
index 6204e33..8f66aa0 100644
--- a/recipes-connectivity/lora/lora-gateway_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
file://lora-gateway-add-spi-path-function.patch \
file://ln-lora-spi-dev.sh \
file://lora-gateway-change-util-tx-continuous-clksrc.patch \
+ file://lora-gateway-semtech-sf12.patch \
"
SRC_URI[md5sum] = "9e06a3733a9fea39a3d61f77b412badf"
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.22.bb b/recipes-connectivity/lora/lora-network-server_1.0.22.bb
deleted file mode 100644
index c6b90d6..0000000
--- a/recipes-connectivity/lora/lora-network-server_1.0.22.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION = "MultiTech LoRa Network Server"
-PRIORITY = "optional"
-SECTION = "console/utils"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
-DEPENDS = "jsoncpp libmts mosquitto sqlite3"
-RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
-PR = "r1"
-
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
- file://lora-network-server.init \
- file://lora-network-server.default \
- file://lora-network-server.logrotate.conf \
- "
-
-SRC_URI[md5sum] = "100b46847aedf418b07e4a02986f7133"
-SRC_URI[sha256sum] = "3da7223de83b558f4e1689c0d8f0fa34c2e4e7faecaa1372495c0e579db96efc"
-
-# binaries are already stripped, so suppress warning
-INSANE_SKIP_${PN} = "already-stripped"
-
-S = "${WORKDIR}"
-
-LORA_DIR = "/opt/lora"
-
-do_compile() {
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "lora-network-server"
-INITSCRIPT_PARAMS = "defaults 80 30"
-
-do_install() {
- install -d ${D}${LORA_DIR}
- install -m 0755 lora-network-server ${D}${LORA_DIR}/
- install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
- install -d ${D}${sysconfdir}/logrotate.d
- install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
-}
-
-CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
-FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.23.bb b/recipes-connectivity/lora/lora-network-server_1.0.23.bb
deleted file mode 100644
index addd238..0000000
--- a/recipes-connectivity/lora/lora-network-server_1.0.23.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION = "MultiTech LoRa Network Server"
-PRIORITY = "optional"
-SECTION = "console/utils"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
-DEPENDS = "jsoncpp libmts mosquitto sqlite3"
-RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
-PR = "r1"
-
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
- file://lora-network-server.init \
- file://lora-network-server.default \
- file://lora-network-server.logrotate.conf \
- "
-
-SRC_URI[md5sum] = "453788c7a3b52aca771e9cf3b26d49a2"
-SRC_URI[sha256sum] = "1a9a1c886b42a09e640fd85a87897052986b510bbddec0b9597575980e880d86"
-
-# binaries are already stripped, so suppress warning
-INSANE_SKIP_${PN} = "already-stripped"
-
-S = "${WORKDIR}"
-
-LORA_DIR = "/opt/lora"
-
-do_compile() {
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "lora-network-server"
-INITSCRIPT_PARAMS = "defaults 80 30"
-
-do_install() {
- install -d ${D}${LORA_DIR}
- install -m 0755 lora-network-server ${D}${LORA_DIR}/
- install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
- install -d ${D}${sysconfdir}/logrotate.d
- install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
-}
-
-CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
-FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"