summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-11-28 16:10:18 -0600
committerBrandon Bayer <bbayer@multitech.com>2016-11-28 16:10:47 -0600
commitcc493ab08f771ec4b82087c91c76f65be2b384d8 (patch)
tree9553a10a0616590730a02c9d7d59e84278d11989
parent732fcf77f5e44524e10d1a3a565b1d3debf7b354 (diff)
downloadmeta-mlinux-cc493ab08f771ec4b82087c91c76f65be2b384d8.tar.gz
meta-mlinux-cc493ab08f771ec4b82087c91c76f65be2b384d8.tar.bz2
meta-mlinux-cc493ab08f771ec4b82087c91c76f65be2b384d8.zip
mtcap:fix: set correct antenna gain in global_conf.json
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic450
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb36
2 files changed, 243 insertions, 243 deletions
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic
index 49c0edd..8f8d93d 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic
+++ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic
@@ -1,225 +1,225 @@
-{
- "SX1301_conf": {
- "lorawan_public": true,
- "clksrc": 0, /* radio_0 provides clock to concentrator */
- "lbt_cfg": {
- "enable": false,
- "rssi_target": 160, /* rssi in dBm = -lbt_rssi_target/2 */
- "nb_channel": 1,
- "start_freq": 869525000,
- "scan_time_us": 5000,
- "tx_delay_1ch_us": 4000000,
- "tx_delay_2ch_us": 4000000
- },
- "antenna_gain": 0, /* antenna gain, in dBi */
- "radio_0": {
- "enable": true,
- "type": "SX1257",
- "freq": 867500000,
- "rssi_offset": -165.0,
- "tx_enable": true,
- "tx_freq_min": 863000000,
- "tx_freq_max": 870000000
- },
- "radio_1": {
- "enable": true,
- "type": "SX1257",
- "freq": 868500000,
- "rssi_offset": -165.0,
- "tx_enable": false
- },
- "chan_multiSF_0": {
- /* Lora MAC channel, 125kHz, all SF, 868.1 MHz */
- "enable": true,
- "radio": 1,
- "if": -400000
- },
- "chan_multiSF_1": {
- /* Lora MAC channel, 125kHz, all SF, 868.3 MHz */
- "enable": true,
- "radio": 1,
- "if": -200000
- },
- "chan_multiSF_2": {
- /* Lora MAC channel, 125kHz, all SF, 868.5 MHz */
- "enable": true,
- "radio": 1,
- "if": 0
- },
- "chan_multiSF_3": {
- /* Lora MAC channel, 125kHz, all SF, 867.1 MHz */
- "enable": true,
- "radio": 0,
- "if": -400000
- },
- "chan_multiSF_4": {
- /* Lora MAC channel, 125kHz, all SF, 867.3 MHz */
- "enable": true,
- "radio": 0,
- "if": -200000
- },
- "chan_multiSF_5": {
- /* Lora MAC channel, 125kHz, all SF, 867.5 MHz */
- "enable": true,
- "radio": 0,
- "if": 0
- },
- "chan_multiSF_6": {
- /* Lora MAC channel, 125kHz, all SF, 867.7 MHz */
- "enable": true,
- "radio": 0,
- "if": 200000
- },
- "chan_multiSF_7": {
- /* Lora MAC channel, 125kHz, all SF, 867.9 MHz */
- "enable": true,
- "radio": 0,
- "if": 400000
- },
- "chan_Lora_std": {
- /* Lora MAC channel, 250kHz, SF7, 868.3 MHz */
- "enable": true,
- "radio": 1,
- "if": -200000,
- "bandwidth": 250000,
- "spread_factor": 7
- },
- "chan_FSK": {
- /* FSK 50kbps channel, 868.8 MHz */
- "enable": true,
- "radio": 1,
- "if": 300000,
- "bandwidth": 125000,
- "datarate": 50000
- },
- "tx_lut_0": {
- /* TX gain table, index 0 */
- "pa_gain": 0,
- "mix_gain": 9,
- "rf_power": -6,
- "dig_gain": 1
- },
- "tx_lut_1": {
- /* TX gain table, index 1 */
- "pa_gain": 0,
- "mix_gain": 12,
- "rf_power": -3,
- "dig_gain": 1
- },
- "tx_lut_2": {
- /* TX gain table, index 2 */
- "pa_gain": 1,
- "mix_gain": 8,
- "rf_power": 0,
- "dig_gain": 2
- },
- "tx_lut_3": {
- /* TX gain table, index 3 */
- "pa_gain": 1,
- "mix_gain": 11,
- "rf_power": 3,
- "dig_gain": 3
- },
- "tx_lut_4": {
- /* TX gain table, index 4 */
- "pa_gain": 1,
- "mix_gain": 10,
- "rf_power": 6,
- "dig_gain": 0
- },
- "tx_lut_5": {
- /* TX gain table, index 5 */
- "pa_gain": 2,
- "mix_gain": 11,
- "rf_power": 10,
- "dig_gain": 3
- },
- "tx_lut_6": {
- /* TX gain table, index 6 */
- "pa_gain": 2,
- "mix_gain": 9,
- "rf_power": 11,
- "dig_gain": 1
- },
- "tx_lut_7": {
- /* TX gain table, index 7 */
- "pa_gain": 2,
- "mix_gain": 9,
- "rf_power": 12,
- "dig_gain": 0
- },
- "tx_lut_8": {
- /* TX gain table, index 8 */
- "pa_gain": 2,
- "mix_gain": 11,
- "rf_power": 13,
- "dig_gain": 2
- },
- "tx_lut_9": {
- /* TX gain table, index 9 */
- "pa_gain": 2,
- "mix_gain": 11,
- "rf_power": 14,
- "dig_gain": 1
- },
- "tx_lut_10": {
- /* TX gain table, index 10 */
- "pa_gain": 2,
- "mix_gain": 12,
- "rf_power": 16,
- "dig_gain": 0
- },
- "tx_lut_11": {
- /* TX gain table, index 11 */
- "pa_gain": 3,
- "mix_gain": 10,
- "rf_power": 20,
- "dig_gain": 3
- },
- "tx_lut_12": {
- /* TX gain table, index 12 */
- "pa_gain": 3,
- "mix_gain": 9,
- "rf_power": 23,
- "dig_gain": 0
- },
- "tx_lut_13": {
- /* TX gain table, index 13 */
- "pa_gain": 3,
- "mix_gain": 12,
- "rf_power": 25,
- "dig_gain": 2
- },
- "tx_lut_14": {
- /* TX gain table, index 14 */
- "pa_gain": 3,
- "mix_gain": 13,
- "rf_power": 26,
- "dig_gain": 0
- },
- "tx_lut_15": {
- /* TX gain table, index 15 */
- "pa_gain": 3,
- "mix_gain": 15,
- "rf_power": 27,
- "dig_gain": 0
- }
- },
-
- "gateway_conf": {
- "gateway_ID": "AA555A0000000000",
- /* change with default server address/ports, or overwrite in local_conf.json */
- "server_address": "localhost",
- "serv_port_up": 1680,
- "serv_port_down": 1680,
- /* adjust the following parameters for your network */
- "keepalive_interval": 10,
- "stat_interval": 30,
- "push_timeout_ms": 100,
- /* forward only valid packets */
- "forward_crc_valid": true,
- "forward_crc_error": false,
- "forward_crc_disabled": false
- }
-}
-
+{
+ "SX1301_conf": {
+ "lorawan_public": true,
+ "clksrc": 0, /* radio_0 provides clock to concentrator */
+ "lbt_cfg": {
+ "enable": false,
+ "rssi_target": 160, /* rssi in dBm = -lbt_rssi_target/2 */
+ "nb_channel": 1,
+ "start_freq": 869525000,
+ "scan_time_us": 5000,
+ "tx_delay_1ch_us": 4000000,
+ "tx_delay_2ch_us": 4000000
+ },
+ "antenna_gain": 1.4, /* antenna gain, in dBi */
+ "radio_0": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 867500000,
+ "rssi_offset": -165.0,
+ "tx_enable": true,
+ "tx_freq_min": 863000000,
+ "tx_freq_max": 870000000
+ },
+ "radio_1": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 868500000,
+ "rssi_offset": -165.0,
+ "tx_enable": false
+ },
+ "chan_multiSF_0": {
+ /* Lora MAC channel, 125kHz, all SF, 868.1 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -400000
+ },
+ "chan_multiSF_1": {
+ /* Lora MAC channel, 125kHz, all SF, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000
+ },
+ "chan_multiSF_2": {
+ /* Lora MAC channel, 125kHz, all SF, 868.5 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 0
+ },
+ "chan_multiSF_3": {
+ /* Lora MAC channel, 125kHz, all SF, 867.1 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -400000
+ },
+ "chan_multiSF_4": {
+ /* Lora MAC channel, 125kHz, all SF, 867.3 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -200000
+ },
+ "chan_multiSF_5": {
+ /* Lora MAC channel, 125kHz, all SF, 867.5 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 0
+ },
+ "chan_multiSF_6": {
+ /* Lora MAC channel, 125kHz, all SF, 867.7 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 200000
+ },
+ "chan_multiSF_7": {
+ /* Lora MAC channel, 125kHz, all SF, 867.9 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 400000
+ },
+ "chan_Lora_std": {
+ /* Lora MAC channel, 250kHz, SF7, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000,
+ "bandwidth": 250000,
+ "spread_factor": 7
+ },
+ "chan_FSK": {
+ /* FSK 50kbps channel, 868.8 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 300000,
+ "bandwidth": 125000,
+ "datarate": 50000
+ },
+ "tx_lut_0": {
+ /* TX gain table, index 0 */
+ "pa_gain": 0,
+ "mix_gain": 9,
+ "rf_power": -6,
+ "dig_gain": 1
+ },
+ "tx_lut_1": {
+ /* TX gain table, index 1 */
+ "pa_gain": 0,
+ "mix_gain": 12,
+ "rf_power": -3,
+ "dig_gain": 1
+ },
+ "tx_lut_2": {
+ /* TX gain table, index 2 */
+ "pa_gain": 1,
+ "mix_gain": 8,
+ "rf_power": 0,
+ "dig_gain": 2
+ },
+ "tx_lut_3": {
+ /* TX gain table, index 3 */
+ "pa_gain": 1,
+ "mix_gain": 11,
+ "rf_power": 3,
+ "dig_gain": 3
+ },
+ "tx_lut_4": {
+ /* TX gain table, index 4 */
+ "pa_gain": 1,
+ "mix_gain": 10,
+ "rf_power": 6,
+ "dig_gain": 0
+ },
+ "tx_lut_5": {
+ /* TX gain table, index 5 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 10,
+ "dig_gain": 3
+ },
+ "tx_lut_6": {
+ /* TX gain table, index 6 */
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 11,
+ "dig_gain": 1
+ },
+ "tx_lut_7": {
+ /* TX gain table, index 7 */
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 12,
+ "dig_gain": 0
+ },
+ "tx_lut_8": {
+ /* TX gain table, index 8 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 13,
+ "dig_gain": 2
+ },
+ "tx_lut_9": {
+ /* TX gain table, index 9 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 14,
+ "dig_gain": 1
+ },
+ "tx_lut_10": {
+ /* TX gain table, index 10 */
+ "pa_gain": 2,
+ "mix_gain": 12,
+ "rf_power": 16,
+ "dig_gain": 0
+ },
+ "tx_lut_11": {
+ /* TX gain table, index 11 */
+ "pa_gain": 3,
+ "mix_gain": 10,
+ "rf_power": 20,
+ "dig_gain": 3
+ },
+ "tx_lut_12": {
+ /* TX gain table, index 12 */
+ "pa_gain": 3,
+ "mix_gain": 9,
+ "rf_power": 23,
+ "dig_gain": 0
+ },
+ "tx_lut_13": {
+ /* TX gain table, index 13 */
+ "pa_gain": 3,
+ "mix_gain": 12,
+ "rf_power": 25,
+ "dig_gain": 2
+ },
+ "tx_lut_14": {
+ /* TX gain table, index 14 */
+ "pa_gain": 3,
+ "mix_gain": 13,
+ "rf_power": 26,
+ "dig_gain": 0
+ },
+ "tx_lut_15": {
+ /* TX gain table, index 15 */
+ "pa_gain": 3,
+ "mix_gain": 15,
+ "rf_power": 27,
+ "dig_gain": 0
+ }
+ },
+
+ "gateway_conf": {
+ "gateway_ID": "AA555A0000000000",
+ /* change with default server address/ports, or overwrite in local_conf.json */
+ "server_address": "localhost",
+ "serv_port_up": 1680,
+ "serv_port_down": 1680,
+ /* adjust the following parameters for your network */
+ "keepalive_interval": 10,
+ "stat_interval": 30,
+ "push_timeout_ms": 100,
+ /* forward only valid packets */
+ "forward_crc_valid": true,
+ "forward_crc_error": false,
+ "forward_crc_disabled": false
+ }
+}
+
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
index 834ff6c..cafa265 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -32,34 +32,34 @@ export LGW_INC = "${STAGING_INCDIR}/lora"
CFLAGS += "-I${LGW_INC} -Iinc -I."
do_compile() {
- oe_runmake
+ oe_runmake
}
do_install() {
- install -d ${D}${LORA_DIR}
- install -m 755 lora_pkt_fwd/lora_pkt_fwd ${D}${LORA_DIR}/
- install -m 755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
+ install -d ${D}${LORA_DIR}
+ install -m 755 lora_pkt_fwd/lora_pkt_fwd ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
- install -d ${D}${LORA_DIR}/forwarder-utils
- install -m 755 util_sink/util_sink ${D}${LORA_DIR}/forwarder-utils/
- install -m 755 util_ack/util_ack ${D}${LORA_DIR}/forwarder-utils/
- install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/forwarder-utils/
- install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
+ install -d ${D}${LORA_DIR}/forwarder-utils
+ install -m 755 util_sink/util_sink ${D}${LORA_DIR}/forwarder-utils/
+ install -m 755 util_ack/util_ack ${D}${LORA_DIR}/forwarder-utils/
+ install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/forwarder-utils/
+ install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
}
do_install_append_mtcdt() {
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
}
do_install_append_mtcap() {
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic ${D}${LORA_DIR}/global_conf.json
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic ${D}${LORA_DIR}/global_conf.json
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/lora-packet-forwarder.default ${D}${sysconfdir}/default/lora-packet-forwarder
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lora-packet-forwarder.init ${D}${sysconfdir}/init.d/lora-packet-forwarder
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-packet-forwarder.default ${D}${sysconfdir}/default/lora-packet-forwarder
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-packet-forwarder.init ${D}${sysconfdir}/init.d/lora-packet-forwarder
}
FILES_${PN} += "${LORA_DIR}"
@@ -67,5 +67,5 @@ FILES_${PN}-dbg += "${LORA_DIR}/.debug ${LORA_DIR}/forwarder-utils/.debug"
# disable this on purpose for dev purposes
do_rm_work() {
- echo "skipping"
+ echo "skipping"
}