summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-11-21 14:49:01 -0600
committerJason Reiss <jreiss@multitech.com>2016-11-21 14:49:01 -0600
commit243c84d7e76aaa7493e0e08ae4de8d89d0a3d594 (patch)
tree303a0c2ca75af0e560388d3f7b2b8ef771884fff
parent92537cc9d8a645d34b58dcca3f0ceabc564ce86e (diff)
parente1096eb058303e3c201f2055df742238831289a2 (diff)
downloadmeta-mlinux-243c84d7e76aaa7493e0e08ae4de8d89d0a3d594.tar.gz
meta-mlinux-243c84d7e76aaa7493e0e08ae4de8d89d0a3d594.tar.bz2
meta-mlinux-243c84d7e76aaa7493e0e08ae4de8d89d0a3d594.zip
Merge branch 'master' of gitlab.multitech.net:mirrors/meta-mlinux
-rw-r--r--classes/mlinux-image.bbclass16
-rw-r--r--conf/distro/mlinux.conf4
-rw-r--r--recipes-connectivity/lora/lora-gateway_4.0.1.bb7
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic225
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb14
-rw-r--r--recipes-core/images/mlinux-base-image.bb4
-rw-r--r--recipes-core/images/mlinux-factory-image.bb4
-rw-r--r--recipes-core/images/mlinux-rs9113-base-image.bb5
-rw-r--r--recipes-core/images/mlinux-rs9113-factory-image.bb (renamed from recipes-core/images/mlinux-xrs9113-factory-image.bb)5
-rw-r--r--recipes-core/images/mlinux-xrs9113-base-image.bb65
-rw-r--r--recipes-extended/monit/monit_5.12.2.bb1
-rw-r--r--recipes-navigation/gpsd/gpsd/Conduit.patch14
-rw-r--r--recipes-navigation/gpsd/gpsd_3.7.bbappend10
-rwxr-xr-xscripts/build-feed-extras.sh2
14 files changed, 292 insertions, 84 deletions
diff --git a/classes/mlinux-image.bbclass b/classes/mlinux-image.bbclass
index 13cacb5..4af7d9e 100644
--- a/classes/mlinux-image.bbclass
+++ b/classes/mlinux-image.bbclass
@@ -12,18 +12,24 @@ mlinux_set_root_password () {
}
ROOTFS_POSTPROCESS_COMMAND += "mlinux_set_root_password;"
-# set custom product sw version to /etc/issue file if $FIRMWARE_PRODUCT_VER is set
+# set custom product sw version to /etc/issue file
mlinux_set_product_version () {
- if [ -n "${FIRMWARE_PRODUCT_VER}" ]; then
+ PREV_DIR=$(pwd)
+ cd "$TOPDIR"
+ PRODUCT_VER=$(git describe)
+ cd "$PREV_DIR"
+ PRODUCT_DATE=$(date +%Y-%m-%dT%H:%M:%S)
+
+ if [ -n "${PRODUCT_VER}" ]; then
# set issue
if cat ${IMAGE_ROOTFS}/etc/issue | grep "Version: " > /dev/null 2>&1 ; then
# replace
- sed -i "s/^Version: .*$/Version: $FIRMWARE_PRODUCT_VER/g" ${IMAGE_ROOTFS}/etc/issue
- sed -i "s/^Date: .*$/Date: $FIRMWARE_PRODUCT_DATE/g" ${IMAGE_ROOTFS}/etc/issue
+ sed -i "s/^Version: .*$/Version: $PRODUCT_VER/g" ${IMAGE_ROOTFS}/etc/issue
+ sed -i "s/^Date: .*$/Date: $PRODUCT_DATE/g" ${IMAGE_ROOTFS}/etc/issue
else
# add
echo "" >> ${IMAGE_ROOTFS}/etc/issue
- echo "Version: ${FIRMWARE_PRODUCT_VER}" >> ${IMAGE_ROOTFS}/etc/issue
+ echo "Version: ${PRODUCT_VER}" >> ${IMAGE_ROOTFS}/etc/issue
echo "Date: $(date +%Y-%m-%dT%H:%M:%S)" >> ${IMAGE_ROOTFS}/etc/issue
fi
fi
diff --git a/conf/distro/mlinux.conf b/conf/distro/mlinux.conf
index 9be1ca1..31b61aa 100644
--- a/conf/distro/mlinux.conf
+++ b/conf/distro/mlinux.conf
@@ -1,8 +1,8 @@
DISTRO = "mlinux"
DISTRO_NAME = "mLinux"
DISTRO_BASE_VERSION = "3.2"
-DISTRO_VERSION = "${DISTRO_BASE_VERSION}.1dev1"
-DISTRO_CODENAME = "dev1"
+DISTRO_VERSION = "${DISTRO_BASE_VERSION}.1"
+DISTRO_CODENAME = "dev2"
SDK_VENDOR = "-mlinux"
SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
SDK_NAME = "${DISTRO}-${TCLIBC}-${SDK_ARCH}-${IMAGE_BASENAME}-${TUNE_PKGARCH}"
diff --git a/recipes-connectivity/lora/lora-gateway_4.0.1.bb b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
index 5e269e1..6204e33 100644
--- a/recipes-connectivity/lora/lora-gateway_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
DEPENDS = ""
-PR = "r8"
+PR = "r9"
SRCREV = "v${PV}"
SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
@@ -42,7 +42,6 @@ do_install() {
install -m 0644 libloragw/readme.md ${D}${libdir}/lora/lora-gw-readme.md
install -d ${D}/opt/lora/
- install -m 0755 ${WORKDIR}/ln-lora-spi-dev.sh ${D}/opt/lora/
install -d ${D}/opt/lora/gateway-utils
install -m 0755 libloragw/test_* ${D}/opt/lora/gateway-utils/
@@ -54,6 +53,10 @@ do_install() {
install -m 0755 util_lbt_test/util_lbt_test ${D}/opt/lora/gateway-utils/
}
+do_install_append_mtcdt() {
+ install -m 0755 ${WORKDIR}/ln-lora-spi-dev.sh ${D}/opt/lora/
+}
+
PACKAGES += "${PN}-utils ${PN}-utils-dbg"
FILES_${PN} = "${libdir}/lora/lora-gw-readme.md"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic
new file mode 100644
index 0000000..49c0edd
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic
@@ -0,0 +1,225 @@
+{
+ "SX1301_conf": {
+ "lorawan_public": true,
+ "clksrc": 0, /* radio_0 provides clock to concentrator */
+ "lbt_cfg": {
+ "enable": false,
+ "rssi_target": 160, /* rssi in dBm = -lbt_rssi_target/2 */
+ "nb_channel": 1,
+ "start_freq": 869525000,
+ "scan_time_us": 5000,
+ "tx_delay_1ch_us": 4000000,
+ "tx_delay_2ch_us": 4000000
+ },
+ "antenna_gain": 0, /* antenna gain, in dBi */
+ "radio_0": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 867500000,
+ "rssi_offset": -165.0,
+ "tx_enable": true,
+ "tx_freq_min": 863000000,
+ "tx_freq_max": 870000000
+ },
+ "radio_1": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 868500000,
+ "rssi_offset": -165.0,
+ "tx_enable": false
+ },
+ "chan_multiSF_0": {
+ /* Lora MAC channel, 125kHz, all SF, 868.1 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -400000
+ },
+ "chan_multiSF_1": {
+ /* Lora MAC channel, 125kHz, all SF, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000
+ },
+ "chan_multiSF_2": {
+ /* Lora MAC channel, 125kHz, all SF, 868.5 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 0
+ },
+ "chan_multiSF_3": {
+ /* Lora MAC channel, 125kHz, all SF, 867.1 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -400000
+ },
+ "chan_multiSF_4": {
+ /* Lora MAC channel, 125kHz, all SF, 867.3 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -200000
+ },
+ "chan_multiSF_5": {
+ /* Lora MAC channel, 125kHz, all SF, 867.5 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 0
+ },
+ "chan_multiSF_6": {
+ /* Lora MAC channel, 125kHz, all SF, 867.7 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 200000
+ },
+ "chan_multiSF_7": {
+ /* Lora MAC channel, 125kHz, all SF, 867.9 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 400000
+ },
+ "chan_Lora_std": {
+ /* Lora MAC channel, 250kHz, SF7, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000,
+ "bandwidth": 250000,
+ "spread_factor": 7
+ },
+ "chan_FSK": {
+ /* FSK 50kbps channel, 868.8 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 300000,
+ "bandwidth": 125000,
+ "datarate": 50000
+ },
+ "tx_lut_0": {
+ /* TX gain table, index 0 */
+ "pa_gain": 0,
+ "mix_gain": 9,
+ "rf_power": -6,
+ "dig_gain": 1
+ },
+ "tx_lut_1": {
+ /* TX gain table, index 1 */
+ "pa_gain": 0,
+ "mix_gain": 12,
+ "rf_power": -3,
+ "dig_gain": 1
+ },
+ "tx_lut_2": {
+ /* TX gain table, index 2 */
+ "pa_gain": 1,
+ "mix_gain": 8,
+ "rf_power": 0,
+ "dig_gain": 2
+ },
+ "tx_lut_3": {
+ /* TX gain table, index 3 */
+ "pa_gain": 1,
+ "mix_gain": 11,
+ "rf_power": 3,
+ "dig_gain": 3
+ },
+ "tx_lut_4": {
+ /* TX gain table, index 4 */
+ "pa_gain": 1,
+ "mix_gain": 10,
+ "rf_power": 6,
+ "dig_gain": 0
+ },
+ "tx_lut_5": {
+ /* TX gain table, index 5 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 10,
+ "dig_gain": 3
+ },
+ "tx_lut_6": {
+ /* TX gain table, index 6 */
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 11,
+ "dig_gain": 1
+ },
+ "tx_lut_7": {
+ /* TX gain table, index 7 */
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 12,
+ "dig_gain": 0
+ },
+ "tx_lut_8": {
+ /* TX gain table, index 8 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 13,
+ "dig_gain": 2
+ },
+ "tx_lut_9": {
+ /* TX gain table, index 9 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 14,
+ "dig_gain": 1
+ },
+ "tx_lut_10": {
+ /* TX gain table, index 10 */
+ "pa_gain": 2,
+ "mix_gain": 12,
+ "rf_power": 16,
+ "dig_gain": 0
+ },
+ "tx_lut_11": {
+ /* TX gain table, index 11 */
+ "pa_gain": 3,
+ "mix_gain": 10,
+ "rf_power": 20,
+ "dig_gain": 3
+ },
+ "tx_lut_12": {
+ /* TX gain table, index 12 */
+ "pa_gain": 3,
+ "mix_gain": 9,
+ "rf_power": 23,
+ "dig_gain": 0
+ },
+ "tx_lut_13": {
+ /* TX gain table, index 13 */
+ "pa_gain": 3,
+ "mix_gain": 12,
+ "rf_power": 25,
+ "dig_gain": 2
+ },
+ "tx_lut_14": {
+ /* TX gain table, index 14 */
+ "pa_gain": 3,
+ "mix_gain": 13,
+ "rf_power": 26,
+ "dig_gain": 0
+ },
+ "tx_lut_15": {
+ /* TX gain table, index 15 */
+ "pa_gain": 3,
+ "mix_gain": 15,
+ "rf_power": 27,
+ "dig_gain": 0
+ }
+ },
+
+ "gateway_conf": {
+ "gateway_ID": "AA555A0000000000",
+ /* change with default server address/ports, or overwrite in local_conf.json */
+ "server_address": "localhost",
+ "serv_port_up": 1680,
+ "serv_port_down": 1680,
+ /* adjust the following parameters for your network */
+ "keepalive_interval": 10,
+ "stat_interval": 30,
+ "push_timeout_ms": 100,
+ /* forward only valid packets */
+ "forward_crc_valid": true,
+ "forward_crc_error": false,
+ "forward_crc_disabled": false
+ }
+}
+
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
index 07ba4a8..834ff6c 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
DEPENDS = "lora-gateway"
-PR = "r5"
+PR = "r7"
SRCREV = "v${PV}"
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://global_conf.json.3.0.0.PCB_E336.EU868.basic.clksrc0 \
file://global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 \
file://global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 \
+ file://global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic \
file://local_conf.json \
file://lora-packet-forwarder-add-spi-dev-path.patch \
"
@@ -37,9 +38,6 @@ do_compile() {
do_install() {
install -d ${D}${LORA_DIR}
install -m 755 lora_pkt_fwd/lora_pkt_fwd ${D}${LORA_DIR}/
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
install -m 755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
install -d ${D}${LORA_DIR}/forwarder-utils
@@ -49,7 +47,15 @@ do_install() {
install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
}
+do_install_append_mtcdt() {
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
+}
+
do_install_append_mtcap() {
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic ${D}${LORA_DIR}/global_conf.json
+
install -d ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/lora-packet-forwarder.default ${D}${sysconfdir}/default/lora-packet-forwarder
install -d ${D}${sysconfdir}/init.d
diff --git a/recipes-core/images/mlinux-base-image.bb b/recipes-core/images/mlinux-base-image.bb
index 6423237..6b19725 100644
--- a/recipes-core/images/mlinux-base-image.bb
+++ b/recipes-core/images/mlinux-base-image.bb
@@ -1,3 +1,4 @@
+# Conduit 0.0 or 0.1 without RS9113
DESCRIPTION = "mLinux base image"
LICENSE = "MIT"
@@ -51,10 +52,9 @@ MULTITECH_FEATURES += " \
reset-handler \
radio-cmd radio-query \
jsparser \
- annex-client \
"
-MISC_FEATURES = "minicom lrzsz nano rs9113"
+MISC_FEATURES = "minicom lrzsz nano"
# Extra stuff to install
IMAGE_INSTALL += " \
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 6cc7197..0f8344e 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -1,3 +1,4 @@
+# Conduit 0.0 or 0.1 without RS9113
require mlinux-base-image.bb
LIGHTTPD = "lighttpd \
@@ -78,6 +79,7 @@ IMAGE_INSTALL += "nodejs nodejs-npm"
IMAGE_INSTALL += "sms-utils"
# Multi-Tech GPS Utility
IMAGE_INSTALL += "venus-gps"
+IMAGE_INSTALL += "pps-tools"
+IMAGE_INSTALL += "gpsd"
IMAGE_INSTALL += "uvccapture"
-
diff --git a/recipes-core/images/mlinux-rs9113-base-image.bb b/recipes-core/images/mlinux-rs9113-base-image.bb
new file mode 100644
index 0000000..a4e9f23
--- /dev/null
+++ b/recipes-core/images/mlinux-rs9113-base-image.bb
@@ -0,0 +1,5 @@
+require mlinux-base-image.bb
+DESCRIPTION = "mLinux base image"
+
+# Extra stuff to install
+IMAGE_INSTALL += " rs9113 "
diff --git a/recipes-core/images/mlinux-xrs9113-factory-image.bb b/recipes-core/images/mlinux-rs9113-factory-image.bb
index fe2e698..bf2beaa 100644
--- a/recipes-core/images/mlinux-xrs9113-factory-image.bb
+++ b/recipes-core/images/mlinux-rs9113-factory-image.bb
@@ -1,4 +1,4 @@
-require mlinux-xrs9113-base-image.bb
+require mlinux-rs9113-base-image.bb
LIGHTTPD = "lighttpd \
lighttpd-module-cgi lighttpd-module-indexfile \
@@ -78,6 +78,7 @@ IMAGE_INSTALL += "nodejs nodejs-npm"
IMAGE_INSTALL += "sms-utils"
# Multi-Tech GPS Utility
IMAGE_INSTALL += "venus-gps"
+IMAGE_INSTALL += "pps-tools"
+IMAGE_INSTALL += "gpsd"
IMAGE_INSTALL += "uvccapture"
-
diff --git a/recipes-core/images/mlinux-xrs9113-base-image.bb b/recipes-core/images/mlinux-xrs9113-base-image.bb
deleted file mode 100644
index b90903a..0000000
--- a/recipes-core/images/mlinux-xrs9113-base-image.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-DESCRIPTION = "mLinux base image"
-LICENSE = "MIT"
-
-require mlinux-minimal-image.bb
-
-FILESYSTEM_FEATURES = "dosfstools \
- cifs-utils \
- lsof \
- "
-
-NETWORKING_FEATURES += "bridge-utils \
- inetutils-ftp \
- openssl \
- rsync \
- iperf \
- mii-diag \
- tcpdump \
- netcat \
- wget \
- strongswan \
- "
-
-WIFI_FEATURES = " \
- libnl \
- wpa-supplicant \
- wireless-tools \
- iw \
- hostap-daemon hostap-utils \
- "
-
-BLUETOOTH_FEATURES = "bluez4"
-
-# Add all timezones available
-# ntpdate will sync time every 30 min by default via cron
-TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
- tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
- tzdata-misc \
- cronie \
- ntpdate \
- "
-
-# u-boot-linux-utils: U-Boot environment access from Linux
-# mlinux-scripts: sample scripts for setting up Conduit for various tasks
-# reset-handler: default reset button handler
-# radio-cmd: supports cellular radio activation and other configuration commands
-# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
-# jsparser: command line tool to parse JSON files
-MULTITECH_FEATURES += " \
- u-boot-linux-utils \
- mlinux-scripts \
- reset-handler \
- radio-cmd radio-query \
- jsparser \
- "
-
-MISC_FEATURES = "minicom lrzsz nano"
-
-# Extra stuff to install
-IMAGE_INSTALL += " \
- ${WIFI_FEATURES} \
- ${BLUETOOTH_FEATURES} \
- ${FILESYSTEM_FEATURES} \
- ${TIME_FEATURES} \
- ${MISC_FEATURES} \
- "
diff --git a/recipes-extended/monit/monit_5.12.2.bb b/recipes-extended/monit/monit_5.12.2.bb
index 017ac75..ddd2ea9 100644
--- a/recipes-extended/monit/monit_5.12.2.bb
+++ b/recipes-extended/monit/monit_5.12.2.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Monit"
HOMEPAGE = "http://mmonit.com/"
LICENSE = "AGPL-3.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=ea116a7defaf0e93b3bb73b2a34a3f51"
+DEPENDS = "libpam"
PR = "r1"
diff --git a/recipes-navigation/gpsd/gpsd/Conduit.patch b/recipes-navigation/gpsd/gpsd/Conduit.patch
new file mode 100644
index 0000000..0fced15
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd/Conduit.patch
@@ -0,0 +1,14 @@
+diff -uprN old/gpsd new/gpsd
+--- old/gpsd 2016-11-14 14:37:19.733762786 -0600
++++ new/gpsd 2016-11-14 14:43:28.733762007 -0600
+@@ -93,6 +93,10 @@ do_reload() {
+
+ case "$1" in
+ start)
++ if ! [[ -r /sys/devices/platform/mts-io/gnss-int ]] ; then
++ echo "No GPS available"
++ exit
++ fi
+ echo "Starting $DESC" "$NAME"
+ do_start
+ exit $?
diff --git a/recipes-navigation/gpsd/gpsd_3.7.bbappend b/recipes-navigation/gpsd/gpsd_3.7.bbappend
new file mode 100644
index 0000000..73b814f
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd_3.7.bbappend
@@ -0,0 +1,10 @@
+PR .= ".mlinux1"
+
+SRC_URI += " file://Conduit.patch;patchdir=.."
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
+
+python do_patch_prepend () {
+ import os
+ cwd = os.getcwd()
+ bb.note("Hello %s",cwd)
+}
diff --git a/scripts/build-feed-extras.sh b/scripts/build-feed-extras.sh
index be3b86c..be12672 100755
--- a/scripts/build-feed-extras.sh
+++ b/scripts/build-feed-extras.sh
@@ -5,6 +5,6 @@ FS_PACKAGES="sshfs-fuse fuse-exfat exfat-utils"
NET_PACKAGES="wget netcat ipsec-tools openvpn iftop dnsmasq strongswan stunnel tunctl"
UTIL_PACKAGES="logrotate fatrace stressapptest gawk rsyslog zip gnupg rrdtool"
DEV_PACKAGES="node-red mono gdb git vim python-pip python-pyopenssl"
-SUP_PACKAGES="pps-tools"
+SUP_PACKAGES="pps-tools setserial"
bitbake linux-firmware $FS_PACKAGES $NET_PACKAGES $UTIL_PACKAGES $DEV_PACKAGES $SUP_PACKAGES