summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-02-24 13:56:54 -0600
committerJesse Gilles <jgilles@multitech.com>2015-02-24 13:58:47 -0600
commit7d3e97d354ae2f73e1f0f113e47c72c014341757 (patch)
treea1d3d1916750814a644cd8e6fc9659b1ba8c8b1d
parentb72c8c2db2254bda8606ff34f0ee001d9899c2b8 (diff)
downloadmeta-mlinux-7d3e97d354ae2f73e1f0f113e47c72c014341757.tar.gz
meta-mlinux-7d3e97d354ae2f73e1f0f113e47c72c014341757.tar.bz2
meta-mlinux-7d3e97d354ae2f73e1f0f113e47c72c014341757.zip
add libftdi_1.1.bb
-rw-r--r--recipes-support/libftdi/libftdi_1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-support/libftdi/libftdi_1.1.bb b/recipes-support/libftdi/libftdi_1.1.bb
new file mode 100644
index 0000000..d8b189b
--- /dev/null
+++ b/recipes-support/libftdi/libftdi_1.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "libftdi is a library to talk to FTDI chips.\
+FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\
+including the popular bitbang mode."
+HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM= "\
+ file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
+ file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
+"
+
+DEPENDS = "libusb1"
+
+SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "b79a6356978aa8e69f8eecc3a720ff79"
+SRC_URI[sha256sum] = "c0b1af1a13e2c6682a1d8041e5b164a1e0d90267cd378bb51e059bd62f821e21"
+
+S = "${WORKDIR}/${BPN}1-${PV}"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on,-DFTDI_BUILD_CPP=off,boost"
+
+inherit cmake binconfig pkgconfig
+
+FILES_${PN}-dev += "${libdir}/cmake"
+
+BBCLASSEXTEND = "native"