summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-09-01 09:09:36 -0500
committerJohn Klug <john.klug@multitech.com>2017-09-01 09:09:36 -0500
commitca835f99b87a3432811b9eb2c89c63faf1315353 (patch)
treef28b0752f5ad56797ce74224c48c79484b47e089
parent059c1482875feb1d57fd679e8fc2d27c6f9e63d1 (diff)
downloadmeta-mlinux-ca835f99b87a3432811b9eb2c89c63faf1315353.tar.gz
meta-mlinux-ca835f99b87a3432811b9eb2c89c63faf1315353.tar.bz2
meta-mlinux-ca835f99b87a3432811b9eb2c89c63faf1315353.zip
Implement automatic switch. Remove non-working parts of bitbake recipe.
-rw-r--r--recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.default4
-rw-r--r--recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.init2
-rw-r--r--recipes-core/multitech/cell-radio-carrierswitch_1.0.bb10
3 files changed, 4 insertions, 12 deletions
diff --git a/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.default b/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.default
index 42bc1b0..7128721 100644
--- a/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.default
+++ b/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.default
@@ -1,5 +1,5 @@
-# set to "yes" to enable cell-radio-fwswitch on boot
-ENABLED="no"
+# set to "no" to disable cell-radio-fwswitch on boot
+ENABLED="yes"
# The default timeout is 60 seconds.
# It depends on how long your radio takes to get ready.
diff --git a/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.init b/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.init
index 32b8d0d..6b8a640 100644
--- a/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.init
+++ b/recipes-core/multitech/cell-radio-carrierswitch/cell-radio-carrierswitch.init
@@ -3,7 +3,7 @@
# no firmware switch by default
ENABLED="no"
-[ -r /etc/default/cell-radio-fwswitch ] && source /etc/default/cell-radio-fwswitch
+[ -r /etc/default/cell-radio-carrierswitch ] && source /etc/default/cell-radio-carrierswitch
[ "$ENABLED" == "yes" ] || exit 0
# It may take a couple of boots to get the APN straightened out.
diff --git a/recipes-core/multitech/cell-radio-carrierswitch_1.0.bb b/recipes-core/multitech/cell-radio-carrierswitch_1.0.bb
index 6302779..0220dba 100644
--- a/recipes-core/multitech/cell-radio-carrierswitch_1.0.bb
+++ b/recipes-core/multitech/cell-radio-carrierswitch_1.0.bb
@@ -15,19 +15,11 @@ SRC_URI = "\
file://cell-radio-carrierswitch.init \
"
-do_install_mtcap() {
+do_install() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/cell-radio-carrierswitch.init ${D}${sysconfdir}/init.d/cell-radio-carrierswitch
install -d ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/cell-radio-carrierswitch.default ${D}${sysconfdir}/default/cell-radio-carrierswitch
- sed -i 's/ENABLED="no"/ENABLED="yes"/g' ${D}${sysconfdir}/default/cell-radio-carrierswitch
}
-do_install_mtcdt() {
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/cell-radio-carrierswitch.init ${D}${sysconfdir}/init.d/cell-radio-carrierswitch
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/cell-radio-carrierswitch.default ${D}${sysconfdir}/default/cell-radio-carrierswitch
-}