summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-11-09 18:16:00 -0600
committerJohn Klug <john.klug@multitech.com>2017-11-09 18:16:00 -0600
commitbff6f679c1a1cd5423d31671bef84c7a743c97fe (patch)
treed3286680a5b5e57ba41ac2c350306bf5a9d56a3f
parentcee6135ac260f8a651aba058cce3c7716a1ded66 (diff)
downloadmeta-mlinux-bff6f679c1a1cd5423d31671bef84c7a743c97fe.tar.gz
meta-mlinux-bff6f679c1a1cd5423d31671bef84c7a743c97fe.tar.bz2
meta-mlinux-bff6f679c1a1cd5423d31671bef84c7a743c97fe.zip
Make init scripts configuration files for AEP compatibility
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon_2.6.bb2
-rw-r--r--recipes-connectivity/openssh/openssh_6.5p1.bbappend1
-rw-r--r--recipes-connectivity/ppp/ppp_%.bbappend3
-rw-r--r--recipes-extended/lighttpd/lighttpd_1.4.33.bbappend2
4 files changed, 5 insertions, 3 deletions
diff --git a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
index e9e0f33..e9e0141 100644
--- a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
+++ b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
@@ -32,7 +32,7 @@ do_compile() {
make
}
-CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
+CONFFILES_${PN} += "${sysconfdir}/hostapd.conf ${sysconfdir}/modprobe.d/cfg80211.conf"
SRC_URI[md5sum] = "eaa56dce9bd8f1d195eb62596eab34c7"
SRC_URI[sha256sum] = "01526b90c1d23bec4b0f052039cc4456c2fd19347b4d830d1d58a0a6aea7117d"
diff --git a/recipes-connectivity/openssh/openssh_6.5p1.bbappend b/recipes-connectivity/openssh/openssh_6.5p1.bbappend
index 87891c8..53d3da1 100644
--- a/recipes-connectivity/openssh/openssh_6.5p1.bbappend
+++ b/recipes-connectivity/openssh/openssh_6.5p1.bbappend
@@ -19,3 +19,4 @@ do_install_append() {
ln -sf /var/config/ssh/$f ${D}${sysconfdir}/ssh/$f
done
}
+CONFFILES_${PN}-sshd += "${sysconfdir}/init.d/sshd"
diff --git a/recipes-connectivity/ppp/ppp_%.bbappend b/recipes-connectivity/ppp/ppp_%.bbappend
index 1c3a023..294933e 100644
--- a/recipes-connectivity/ppp/ppp_%.bbappend
+++ b/recipes-connectivity/ppp/ppp_%.bbappend
@@ -7,7 +7,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
FILES_${PN} += "/etc/default/ppp"
-CONFFILES_${PN} += "${sysconfdir}/default/ppp"
+# AEP compatibility
+CONFFILES_${PN} += "${sysconfdir}/default/ppp ${sysconfdir}/init.d/ppp"
do_install_append() {
install -d -m 0755 ${D}/${sysconfdir}/default/
diff --git a/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend b/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
index 473a113..4187446 100644
--- a/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
+++ b/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
@@ -18,4 +18,4 @@ do_install_append() {
install -m 0644 ${WORKDIR}/lighttpd.default ${D}${sysconfdir}/default/lighttpd
}
-CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf"
+CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf ${sysconfdir}/init.d/lighttpd"