summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-11-16 10:41:10 -0600
committerJohn Klug <john.klug@multitech.com>2017-11-16 10:41:10 -0600
commit28a5c34bcbb2c2ce6896a553e0c988431e9d6d27 (patch)
treed80ba856e87ca34f54bcec99bbccc9b9fb5e31a4
parent40301fa84017562854dfad45dd83572e55800c9d (diff)
downloadmeta-mlinux-28a5c34bcbb2c2ce6896a553e0c988431e9d6d27.tar.gz
meta-mlinux-28a5c34bcbb2c2ce6896a553e0c988431e9d6d27.tar.bz2
meta-mlinux-28a5c34bcbb2c2ce6896a553e0c988431e9d6d27.zip
Add /etc/init.d/node-red to avoid deleting AEP file of same name
-rwxr-xr-xrecipes-devtools/node-red/files/node-red.init5
-rw-r--r--recipes-devtools/node-red/node-red_0.15.3.bb6
2 files changed, 11 insertions, 0 deletions
diff --git a/recipes-devtools/node-red/files/node-red.init b/recipes-devtools/node-red/files/node-red.init
new file mode 100755
index 0000000..05df9ad
--- /dev/null
+++ b/recipes-devtools/node-red/files/node-red.init
@@ -0,0 +1,5 @@
+#!/bin/bash
+# This is a placeholder for AEP's init script to prevent
+# overwriting the node-red init script.
+# This file is not used in non-AEP node-red and should be ignored in all cases.
+true
diff --git a/recipes-devtools/node-red/node-red_0.15.3.bb b/recipes-devtools/node-red/node-red_0.15.3.bb
index d9e9672..dfe1539 100644
--- a/recipes-devtools/node-red/node-red_0.15.3.bb
+++ b/recipes-devtools/node-red/node-red_0.15.3.bb
@@ -5,7 +5,10 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
DEPENDS = "nodejs nodejs-native"
RDEPENDS_${PN} += "bash"
PR = "r0"
+SRC_URI += "file://node-red.init"
+# Added so we do not delete AEP file of same name.
+CONFFILES_${PN} += "${sysconfdir}/init.d/node-red"
inherit npm
S = "${WORKDIR}"
@@ -42,6 +45,9 @@ do_install() {
# install node-red
install -d ${D}/opt/node-red
cp -r ./node_modules/node-red/* ${D}/opt/node-red/
+ # AEP package compatibility
+ install -d -m 0755 ${D}${sysconfdir}/init.d/
+ install -m 0755 ${S}/node-red.init ${D}${sysconfdir}/init.d/node-red
}
FILES_${PN} += "/opt/node-red"