summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/mtr-modules.inc8
-rw-r--r--recipes-core/udev/eudev/mtre/mtre.rules11
-rw-r--r--recipes-core/udev/eudev_%.bbappend2
3 files changed, 19 insertions, 2 deletions
diff --git a/recipes-core/images/mtr-modules.inc b/recipes-core/images/mtr-modules.inc
index f5a57b3..7231dc6 100644
--- a/recipes-core/images/mtr-modules.inc
+++ b/recipes-core/images/mtr-modules.inc
@@ -10,7 +10,13 @@ IMAGE_INSTALL_append_mtr = "\
kernel-module-wlcore \
kernel-module-wlcore-sdio \
"
-# Modules for mtrv1 and mtr
+
+IMAGE_INSTALL_append_mtre = "\
+ kernel-module-leds-pca955x \
+ kernel-module-rtc-ds1307 \
+"
+
+# Modules for mtrv1 and mtr and mtre
IMAGE_INSTALL_append = " \
kernel-module-8021q \
diff --git a/recipes-core/udev/eudev/mtre/mtre.rules b/recipes-core/udev/eudev/mtre/mtre.rules
new file mode 100644
index 0000000..041a763
--- /dev/null
+++ b/recipes-core/udev/eudev/mtre/mtre.rules
@@ -0,0 +1,11 @@
+ACTION=="remove", GOTO="mlinux_end"
+SUBSYSTEM!="tty", GOTO="mlinux_end"
+KERNEL!="ttyUSB[0-9]*|ttyACM[0-9]*|ttyXRUSB[0-9]*|ttyS*", GOTO="mlinux_end"
+
+SUBSYSTEMS=="usb", ENV{ID_IFACE}="$attr{bInterfaceNumber}"
+ENV{ID_IFACE}=="", GOTO="mlinux_end"
+
+# mtre: external serial on exar chip
+ATTRS{idVendor}=="04e2", ATTRS{idProduct}=="1412", ENV{ID_IFACE}=="02", SYMLINK+="ext_serial"
+
+LABEL="mlinux_end"
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index ac17fc2..86c3b9d 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PR .= ".mlinux6"
+PR .= ".mlinux7"
SRC_URI_append_mtcdt = " \
file://accessory_ethernet.rules \