summaryrefslogtreecommitdiff
path: root/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/images/mlinux-rs9113-mtrv1-image.bb')
-rw-r--r--recipes-core/images/mlinux-rs9113-mtrv1-image.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/recipes-core/images/mlinux-rs9113-mtrv1-image.bb b/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
new file mode 100644
index 0000000..da5632c
--- /dev/null
+++ b/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
@@ -0,0 +1,75 @@
+require mtr-modules.inc
+DESCRIPTION = "mLinux base mtr image"
+LICENSE = "MIT"
+
+require mlinux-minimal-image.bb
+MULTITECH_MTAC = ""
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ dnsmasq \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf2 \
+ iperf3 \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ busybox-ifplugd \
+ "
+
+WIFI_FEATURES = " \
+ libnl \
+ wpa-supplicant \
+ iw \
+ hostapd \
+ hostapd-cfg \
+ "
+
+BLUETOOTH_FEATURES = "bluez5 bluez5-pand"
+
+# Add all timezones available
+# ntpdate will sync time every 30 min by default via cron
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+# u-boot-linux-utils: U-Boot environment access from Linux
+# mlinux-scripts: sample scripts for setting up Conduit for various tasks
+# reset-handler: default reset button handler
+# radio-cmd: supports cellular radio activation and other configuration commands
+# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
+# jsparser: command line tool to parse JSON files
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ "
+
+MISC_FEATURES = "minicom lrzsz nano pps-tools"
+
+# Extra stuff to install
+IMAGE_INSTALL += "kernel-module-rs9113 rs9113rf rs9113-util rs9113-utils-extra rs9113-misc rs9113-autostart"
+IMAGE_INSTALL += "gpsd libgps libgps24 ntp ntp-utils gpspipe gps-utils"
+IMAGE_INSTALL += "uxfp"
+CONSOLE = "sysvinit-inittab-start-open"
+
+IMAGE_INSTALL += " \
+ ${WIFI_FEATURES} \
+ ${BLUETOOTH_FEATURES} \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${MISC_FEATURES} \
+ "