summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2020-02-26 08:34:59 -0600
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-21 10:49:34 +0300
commitbb4c79a2c0b881e3a82ef02bb905a0dd7d012e7c (patch)
treed3eea5037f4ac41d7d19527b42e4880c6ad38f4b
parente82919213b8cfab41e9a2e4e966276b992636396 (diff)
downloadmeta-mlinux-atmel-bb4c79a2c0b881e3a82ef02bb905a0dd7d012e7c.tar.gz
meta-mlinux-atmel-bb4c79a2c0b881e3a82ef02bb905a0dd7d012e7c.tar.bz2
meta-mlinux-atmel-bb4c79a2c0b881e3a82ef02bb905a0dd7d012e7c.zip
lora: add LDFLAGS to PKF recipe and jsoncpp to LNS
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.2.42.bb53
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.3.8.bb2
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb1
3 files changed, 2 insertions, 54 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_2.2.42.bb b/recipes-connectivity/lora/lora-network-server_2.2.42.bb
deleted file mode 100644
index d52aaac..0000000
--- a/recipes-connectivity/lora/lora-network-server_2.2.42.bb
+++ /dev/null
@@ -1,53 +0,0 @@
-DESCRIPTION = "MultiTech LoRa Network Server"
-PRIORITY = "optional"
-SECTION = "console/utils"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=2b9a30a3082ddccd2c695a4dbeeab80d"
-DEPENDS = "jsoncpp libmts mosquitto sqlite3 curl gnutls"
-RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging"
-PR = "r0"
-CONFFILES_${PN} += "${sysconfdir}/default/lora-network-server ${sysconfdir}/init.d/lora-network-server"
-
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
- file://lora-network-server.init \
- file://lora-network-server.default \
- "
-
-SRC_URI[md5sum] = "f619c75353fa00aa35628994dbb6c0ff"
-SRC_URI[sha256sum] = "f963a83d44f5aec543ccc3a6574e6ef132c6751a003401401c50e3acbd9b378b"
-
-# binaries are already stripped, so suppress warning
-INSANE_SKIP_${PN} = "already-stripped"
-
-S = "${WORKDIR}"
-
-LORA_DIR = "/opt/lora"
-
-do_compile() {
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "lora-network-server"
-INITSCRIPT_PARAMS = "defaults 80 30"
-
-NETWORK_SERVER_VERSION_mtbsp-at91 = "4"
-NETWORK_SERVER_VERSION_mtbsp-ti = "5"
-NS_ARCH_mtbsp-at91 = ""
-NS_ARCH_mtbsp-ti = "armv7ahf-"
-
-do_install() {
- install -d ${D}${LORA_DIR}
- install -m 0755 lora-network-server-${NS_ARCH}mlinux-${NETWORK_SERVER_VERSION} ${D}${LORA_DIR}/lora-network-server
- install -m 0755 lora-v21-keygen ${D}${LORA_DIR}/lora-v21-keygen
- install -m 0644 config/lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
- install -m 0644 config/lora-network-server.conf.full ${D}${LORA_DIR}/lora-network-server.conf.full
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
-}
-
-FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"
diff --git a/recipes-connectivity/lora/lora-network-server_2.3.8.bb b/recipes-connectivity/lora/lora-network-server_2.3.8.bb
index 61d87cf..77e7726 100644
--- a/recipes-connectivity/lora/lora-network-server_2.3.8.bb
+++ b/recipes-connectivity/lora/lora-network-server_2.3.8.bb
@@ -4,7 +4,7 @@ SECTION = "console/utils"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2b9a30a3082ddccd2c695a4dbeeab80d"
DEPENDS = "jsoncpp libmts mosquitto sqlite3 curl gnutls"
-RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging jsoncpp"
PR = "r0"
CONFFILES_${PN} += "${sysconfdir}/default/lora-network-server ${sysconfdir}/init.d/lora-network-server"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
index 864b1d2..4663ca2 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
@@ -41,6 +41,7 @@ SRC_URI = "git://git@gitlab.multitech.net/lora_enterprise/packet_forwarder_mtac_
S = "${WORKDIR}/git"
B = "${S}"
+TARGET_CC_ARCH += "${LDFLAGS}"
LORA_DIR = "/opt/lora"